Last modified: 2013-09-28 12:27:36 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 42107 - wikieditor-toolbar-help-content-signaturetimestamp-result: Parse error at position 19 in input:
wikieditor-toolbar-help-content-signaturetimestamp-result: Parse error at pos...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
WikiEditor (Other open bugs)
unspecified
All All
: Normal minor with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/w/index.php?t...
: code-update-regression, javascript
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-14 18:54 UTC by rogerhc
Modified: 2013-09-28 12:27 UTC (History)
12 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot (25.00 KB, image/png)
2012-11-16 14:08 UTC, Andre Klapper
Details

Description rogerhc 2012-11-14 18:54:22 UTC
Error observed on en.Wikipedia.org on November 14, 2012, time of this posting.

Edit page has a dropdown Edit help feature above the edit field. I think this is a WikiEditor feature called the Magic Bar. In that click the "Edit" drop down item (between "Special characters" and "Cite", towards right end of bar). At left of dropdown frame is now a scrollable selection area. Scroll to bottom of that and click on the item labeled "Discussion" in there. The two examples of signatures there under "What you get" in right column contain, above the expected example, this error message:

wikieditor-toolbar-help-content-signaturetimestamp-result: Parse error at position 19 in input: 


Hope this helps. Cheers, Roger
Comment 1 Andre Klapper 2012-11-16 14:08:16 UTC
Confirming.
Comment 2 Andre Klapper 2012-11-16 14:08:33 UTC
Created attachment 11375 [details]
Screenshot
Comment 3 Sorawee Porncharoenwase 2013-02-15 04:37:48 UTC
It also occurs at Thai Wikipedia.
Comment 4 Andre Klapper 2013-04-16 08:04:39 UTC
Still valid.

1. Be logged in
2. Go to https://en.wikipedia.org/w/index.php?title=Be_Here_Now_%28album%29&action=edit
3. Click    v Help
4. Scroll down to "Discussion"
5. Click it

See under "What you get":

wikieditor-toolbar-help-content-signature-result: Parse error at position 19 in input: Username (talk)

and others.
Comment 5 Helder 2013-08-31 15:03:59 UTC
This is not Firefox specific (I can reproduce it on Google Chrome 29.0.1547.62).

I installed the extension in my copy of MW and added the code
------------------------------------------------------------------------
if( p === 'wikieditor-toolbar-help-content-signaturetimestamp-result' ){
	console.log( mw.loader.getState( 'mediawiki.jqueryMsg' ) );
}
------------------------------------------------------------------------
right before the line "return mediaWiki.msg( p );" from the function $.wikiEditor.autoMsg[1]. After reloading the page a few times I noticed the following:
* Every time mediawiki.jqueryMsg was "ready" the error occurred
* Every time mediawiki.jqueryMsg was "loaded" there was no error

So, this bug (as well as bug 52479, and probably the one described on bug 51321 comment 12) only happens when the module "mediawiki.jqueryMsg" changes the behavior of the function "mediaWiki.msg" (also known as "mw.msg"). This shorthand is used by WikiEditor since 2010 (see r75491#115), but on
Change-Id: I0d220692262356a12e2f1c0ce30cf6f090428332
the format of the shorthand was modified from "plain" (which WikiEditor was using) to "text".

It is likely that using
return mediaWiki.message( p ).plain();
would solve this.



[1] https://git.wikimedia.org/blob/mediawiki%2Fextensions%2FWikiEditor.git/8981f855a8dfdb3134da18647bb023d1bff3ad7e/modules%2Fjquery.wikiEditor.js#L151
Comment 6 Gerrit Notification Bot 2013-08-31 15:07:43 UTC
Change 82092 had a related patch set uploaded by Helder.wiki:
Use mediaWiki.message( ... ).plain()

https://gerrit.wikimedia.org/r/82092
Comment 7 Gerrit Notification Bot 2013-09-28 12:18:41 UTC
Change 82092 merged by jenkins-bot:
Use mediaWiki.message( ... ).plain()

https://gerrit.wikimedia.org/r/82092

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links