Last modified: 2013-04-22 16:16:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 42019 - Find common range box must always flow left-to-right
Find common range box must always flow left-to-right
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CheckUser (Other open bugs)
unspecified
All All
: Unprioritized enhancement (vote)
: ---
Assigned To: Huji
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2012-11-11 16:43 UTC by Huji
Modified: 2013-04-22 16:16 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
In this screenshot, the content of CIDR box flow from right to left, therefore the text "1 2" (without quotes) look like "2 1" (30.16 KB, image/png)
2013-01-07 00:09 UTC, Huji
Details

Description Huji 2012-11-11 16:43:35 UTC
As of now, "find common range" box follows the content's directionality. This is bad practice because IP address are always left-to-right.
Comment 1 Huji 2012-11-11 16:56:14 UTC
Gerrit change #32920 should fix it.
Comment 2 Huji 2013-01-07 00:09:28 UTC
Created attachment 11596 [details]
In this screenshot, the content of CIDR box flow from right to left, therefore the text "1 2" (without quotes) look like "2 1"

I'm attaching a screenshot, for the sake of clarity of bug report, per saper's request.
Comment 3 Marcin Cieślak 2013-01-07 00:17:17 UTC
To reproduce, I switched by test wiki to:

$wgLanguageCode = "yi";

and set my user prefs to Yiddish, too.

I can confirm that the gerrit patch 32920 changes the directionality of the Javascript IP address entry box.

However, this seems inconsistent with the main CheckUser query box at the top of the form - even with this patch "127.0.0.1" entered there comes in RTL.
Which is understandable, because this fields is also used to enter usernames.

I am a CheckUser on Wikimedia projects, but on an RTL one. It seems inconsistent to me, but for the sake of a good directionality a separate input box of IP addresses should be provided? (I'd prefer a proper HTML solution, not a JavaScript trick hacking the directionality of the existing input box).
Comment 4 Marcin Cieślak 2013-01-07 00:21:45 UTC
I meant I am *not* on the RTL project. I'm CU on plwiki, which is LTR only.
Comment 5 Huji 2013-01-07 00:24:12 UTC
Your observation is correct. The query box follows the directionality of the content, because on many RTL projects, a significant number of users have accounts that are in RTL. That is why I hesitated to change that. Of course, users can switch directionality of that box using browser features (context menu, keyboard shortcut, etc.)

However, CIDR box is solely used for IP address, and it is never needed to be in RTL.
Comment 6 Marcin Cieślak 2013-01-07 00:27:57 UTC
So, the question is, shall we have a separate IP address entry box then?
Comment 7 Huji 2013-01-08 01:28:59 UTC
In my humble opinion, we shouldn't. It adds to confusion. Besides, RTL users are used to this phenomenon (it is not just the CU tool; the MediaWiki proper also has fields where you can enter a username or an IP address, such as on Special:Contribution and we don't have a separate IP field there, so we shouldn't have one for CU either).

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links