Last modified: 2013-11-12 10:36:05 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T43772, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 41772 - Checkuser rights not being correctly applied on
Checkuser rights not being correctly applied on
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
All All
: High critical (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
Blocks: SWMT
  Show dependency treegraph
Reported: 2012-11-05 02:04 UTC by Snowolf
Modified: 2013-11-12 10:36 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Snowolf 2012-11-05 02:04:03 UTC
I granted myself checkuser rights on from meta to perform a routine check, but when I go on testwiki, I don't get access to the CheckUser tool and get instead:

"You do not have permission to check user's IP addresses and other information, for the following reason:

The action you have requested is limited to users in the group: CheckUsers."

see and where I'm listed but the userright doesn't show up.

Not sure where
Comment 1 Nemo 2012-11-05 11:04:34 UTC
testwiki doesn't have any particular configuration about checkuser group as far as I can see, is this a mediawiki bug? Perhaps it should be moved to MediaWiki product (user rights).
Can you reproduce it on any other wiki with local CU and/or same MediaWiki version?
Comment 2 Nemo 2012-11-05 11:08:11 UTC
Also, have you tried assigning yourself steward or crat local right and make yourself CU from local userrights? (To see if it's an interwiki-userrights problem.)
Comment 3 Snowolf 2012-11-05 12:46:34 UTC
Local checkuser is not assignable by local crat or local steward.
Comment 4 Alex Monk 2012-11-05 16:58:39 UTC
It should definitely be assignable by a local steward, as that group has the 'userrights' permission.
Comment 5 Nemo 2012-11-05 17:46:38 UTC
(In reply to comment #4)
> It should definitely be assignable by a local steward, as that group has the
> 'userrights' permission.

Just in case it's not clear (it wasn't clear to me), he tried and failed: 'userrights' permission seems to be giving only the rights which crats have locally.
Snowolf said this happens only on testwiki.
Comment 6 Snowolf 2012-11-05 19:15:42 UTC
(In reply to comment #4)
> It should definitely be assignable by a local steward, as that group has the
> 'userrights' permission.

I gave myself local steward and had no more powers that as local 'crat. Seems to me like the whole userright setup there got some major bugs atm.
Comment 7 Snowolf 2012-11-11 12:09:33 UTC
Just as suddenly as they stopped working, both checkuser and steward userrights resumed their normal work. I don't know if I should close the bug or leave it open so people can figure out what happened :)
Comment 8 Nemo 2012-11-11 13:38:34 UTC
Let's keep it open. It might have been a regression fixed somewhere or some weirdness on fenari, but also something occasionally happening and not yet fixed.
Comment 9 billinghurst 2013-03-11 22:11:59 UTC
This still applies. I was able to replicate it this week.

Live test.  I applied the right from meta,

(show/hide) 22:08, 11 March 2013 Billinghurst (talk | contribs | block) changed group membership for User:Billinghurst@testwiki from (none) to CheckUser (demonstrate fault) 

however, the CheckUser right was is granted but is not applied as expected, note the output here ahows in group, but not the right granted

    Billinghurst (talk | contribs | block) (Created on 13 March 2011 at 01:26)
    Brion VIBBER (talk | contribs | block)‏‎ (bureaucrat, check user, editor, oversight, reviewer, steward, administrator, patroller) (Created on 16 January 2006 at 02:47)
    Mark Bergsma (talk | contribs | block)‏‎ (bureaucrat, check user, editor, importer, oversight, reviewer, administrator, transwiki importer) (Created on 15 August 2007 at 18:14)
    Tim Starling (talk | contribs | block)‏‎ (check user, editor, reviewer, administrator, patroller) (Created on 13 January 2006 at 18:57)
Comment 10 Snowolf 2013-06-06 11:28:12 UTC
It works for me perfectly at the moment, merely took me a couple of moments because testwiki seems to lag behind other wikis, somehow.
Comment 11 billinghurst 2013-11-12 10:36:05 UTC
works for me now, so closing this as WORKSFORME, and presuming that something somewhere changed with testwiki

Note You need to log in before you can comment on or make changes to this bug.