Last modified: 2005-12-04 10:42:57 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T6151, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 4151 - Show extended EXIF details broken
Show extended EXIF details broken
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2005-12-03 01:49 UTC by Chris McKenna
Modified: 2005-12-04 10:42 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Chris McKenna 2005-12-03 01:49:21 UTC
The link to "Show extended details" in the new-style exif box is not currently
working. The link just appends a # to the end the file name, which just takes
you to the top of the current page. i.e. on Image:Foo.jpg clicking the extended
details link takes you to Image:Foo.jpg#

This is happening on en.wp and on commons. I've not tried it elsewhere.
Comment 1 Brion Vibber 2005-12-03 01:54:43 UTC
Works fine for me. Please provide details: exact URLs, browser version,
operating system, logged in / out state, whether you've tried reloads, clearing
cache, etc.
Comment 2 Chris McKenna 2005-12-03 10:31:06 UTC
Example url:
although this happens with all images I've tried. 
It happens on images I've just uplaoded, uploaded a while ago, and on images
I've had nothing to do with.
The same thing happens on en.wp.
It happens whether I'm logged in or not, clearing the cache and/or reloading
makes no difference.
I happens using firefox 1.0 on linux and firefox 1.7 on windows XP, but using
Konqueror 3.2.3 on linux works. I do not have a way of testing on other browsers
at the moment.
Comment 3 Brion Vibber 2005-12-04 00:19:40 UTC
Works fine in Firefox 1.5 on Windows XP for me.

If it continues to happen, please open Firefox's JavaScript Console from the Tools 
menu and check for error messages.
Comment 4 Chris McKenna 2005-12-04 02:38:09 UTC
I've checked the JavaScript Console as suggested. The only errors related to
wikipedia and commons seemed to relate to Lupin's popups script
([[Wikipedia:Tools/Navigation popups]]).
I have checked and the problem happens at en and commons where I have the script
installed, but not at meta or de where I don't.
I presume that as it works for you that you don't use these?

I will ask Lupin to take a look at this bug.
Comment 5 Brion Vibber 2005-12-04 03:59:21 UTC
Indeed I don't use them. Try removing it and check if it clears things up.
Comment 6 Lupin 2005-12-04 04:22:40 UTC
I've believe that I've fixed up my popups script to cooperate with this feature.
Comment 7 Chris McKenna 2005-12-04 10:42:16 UTC
Yes, it now appears to work

Note You need to log in before you can comment on or make changes to this bug.