Last modified: 2013-04-22 16:16:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 40658 - CheckUserLog API: Support for query continue
CheckUserLog API: Support for query continue
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CheckUser (Other open bugs)
master
All All
: Normal normal (vote)
: ---
Assigned To: Grunny
:
: 43943 (view as bug list)
Depends on:
Blocks: noncoreapi
  Show dependency treegraph
 
Reported: 2012-10-01 11:21 UTC by Amalthea
Modified: 2013-04-22 16:16 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Amalthea 2012-10-01 11:21:21 UTC
The ApiQueryCheckUserLog does not support query-continue logic. It would be nice if it did.

In fact, there's actually a bug in the module related to this: It already selects <tt>$limit + 1</tt> rows, presumably because it was based on a module that supported query-continue, so the result currently always contains one more row than requested.
Comment 1 Sam Reed (reedy) 2012-10-01 13:03:29 UTC
(In reply to comment #0)
> In fact, there's actually a bug in the module related to this: It already
> selects <tt>$limit + 1</tt> rows, presumably because it was based on a module
> that supported query-continue, so the result currently always contains one more
> row than requested.

$this->addOption( 'LIMIT', $limit + 1 );

Indeed. It also doesn't check if said results "fit" into the api resultset
Comment 2 Grunny 2012-11-16 08:37:01 UTC
Submitted patch in https://gerrit.wikimedia.org/r/#/c/33702/
Comment 3 Kunal Mehta (Legoktm) 2013-01-13 23:33:07 UTC
*** Bug 43943 has been marked as a duplicate of this bug. ***
Comment 4 Alex Monk 2013-03-10 13:22:39 UTC
Merged by Yurik on the 8th.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links