Last modified: 2012-12-31 18:10:27 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 39972 - jQuery 1.8.1 regressions (tracking)
jQuery 1.8.1 regressions (tracking)
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
JavaScript (Other open bugs)
1.20.x
All All
: Unprioritized major with 1 vote (vote)
: ---
Assigned To: Krinkle
: tracking
Depends on: 39959
Blocks: code_quality 39969
  Show dependency treegraph
 
Reported: 2012-09-04 13:56 UTC by Sam Reed (reedy)
Modified: 2012-12-31 18:10 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sam Reed (reedy) 2012-09-04 13:56:05 UTC
It seems it might have made things worse :(
Comment 1 Sam Reed (reedy) 2012-09-04 14:12:19 UTC
Revert to jQuery 1.7.2 in https://gerrit.wikimedia.org/r/#/c/22555/
Comment 2 Krinkle 2012-09-04 17:12:01 UTC
Guys we need something more tangible than "this blob with 2 million lines of code thrown together from 100+ different modules in browser X on wiki Y is slower".

A revert may do for the short term but not very sustainable, obviously.
Comment 3 Krinkle 2012-09-04 17:13:20 UTC
There's half a dozen things that are significantly improved in performance in jQuery 1.8 over 1.7. We need to narrow it down, a lot.
Comment 4 Krinkle 2012-09-04 17:13:27 UTC
*** Bug 39961 has been marked as a duplicate of this bug. ***
Comment 5 Alex Monk 2012-09-08 13:54:39 UTC
Reverting to 1.7.2 has caused bug 40103
Comment 6 Krinkle 2012-09-10 22:19:11 UTC
*** Bug 40103 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper 2012-12-31 14:23:53 UTC
Reedy: Can this be closed? I don't see any other tickets left here, but I have no idea if you expect further regressions to be found.
Comment 8 Krinkle 2012-12-31 18:10:27 UTC
1.8.1 has been integrated and released without issues.

We've since upgraded twice (to 1.8.2 and 1.8.3).

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links