Last modified: 2012-09-10 22:15:51 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 39969 - Typing process using Narayam significantly slower when using jQuery 1.8.1
Typing process using Narayam significantly slower when using jQuery 1.8.1
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Narayam (Other open bugs)
unspecified
All All
: High critical with 3 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
: code-update-regression
Depends on: 39972
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 12:27 UTC by Subhashish Panigrahi
Modified: 2012-09-10 22:15 UTC (History)
18 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Subhashish Panigrahi 2012-09-04 12:27:32 UTC
Hi, there is a problem with typing on OR WP. Typing using Narayam has become really slow for some reason. When you type something you do not see the transliteration instantly. Instead, it shows up after some time. Can someone please fix it?
Comment 1 Srikanth Logic 2012-09-04 12:34:16 UTC
Can you verify the same in other wikis (commons, translatewiki, etc) ? If its specific to OR WP, you might consider checking your common.js and user scripts you are using.
Comment 2 praveenp 2012-09-04 13:11:01 UTC
This doesn't looks like project specific or user specific problem. I am suffering same problem in meta and ml.wp (where Malayalam as input language). Various other users are also complaining about same problem.
Comment 3 Srikanth Logic 2012-09-04 13:40:28 UTC
This seems to regression due to 1.20wmf11. (Most probably jQuery update)

Copying community members. Please inform your respective village pumps about this bug.
Comment 4 Srikanth Logic 2012-09-04 13:51:21 UTC
Seems to be due to jQuery 1.8.1 update (bug 39908). Works fine with jQuery 1.8.0
Comment 5 Srikanth Logic 2012-09-04 14:59:44 UTC
Seems to be fine after reverting to jQuery 1.7.2
Comment 6 Siebrand Mazeland 2012-09-04 18:43:38 UTC
Reopened after rewording. If MediaWiki were to use jQuery 1.8.1 again, this would simply pop up again. Wikimedia having reverted to jQuery 1.7.2 doesn't fix the root cause.
Comment 7 Derk-Jan Hartman 2012-09-04 18:49:03 UTC
Also, unrelated to this 'visible' problem, Krinkle noted

"btw, I see one big slow down in Narayam though that is bad no matter which version. Use of .live() with half a dozen events + using a proprietary selector ('input:text'). That means every single keydown event  goes up every single element in the tree, all the way up to <html>, and *then* it is handled. First is goes through half a dozen selectors that can't be optimized with native document.querySelector but have to use Sizzle, and then it calls the ev handler'

So irrespective of the workable performance on 1.7.2, that should probably be improved a bit.
Comment 8 Krinkle 2012-09-10 22:15:39 UTC
Fixed in I86cef90be993cef2470fe9a4892bbe55fcce191e.

Whatever is still slow after that change is to be blamed on how Narayam is designed. That needs refactoring later on. There is several major things that are inherently slow.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links