Last modified: 2014-10-27 11:57:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 39381 - Add Javanese font to WebFonts
Add Javanese font to WebFonts
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
WebFonts (Other open bugs)
unspecified
All All
: Normal enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
: i18n, upstream
Depends on: 43297
Blocks: 39960 43359
  Show dependency treegraph
 
Reported: 2012-08-15 14:25 UTC by bennylin
Modified: 2014-10-27 11:57 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
correct rendering using Firefox with graphite enabled (156.96 KB, image/jpeg)
2012-08-31 14:08 UTC, bennylin
Details
wrong rendering using Chrome (and IE) (146.06 KB, image/jpeg)
2012-08-31 14:10 UTC, bennylin
Details

Description bennylin 2012-08-15 14:25:01 UTC
Hi, I'm requesting to activate WebFonts for Javanese script in Javanese Wikipedia.

The font can be obtained in:

http://sites.google.com/site/jawaunicode/download
http://en.wikipedia.org/wiki/Help:Multilingual_support#Javanese

A discussion is currently being held at http://jv.wikipedia.org/wiki/Dhiskusi:Kaca_Utama and I will update the bug after a week or so.
Comment 1 Siebrand Mazeland 2012-08-22 11:09:05 UTC
Any updates yet?
Comment 2 Amir E. Aharoni 2012-08-22 11:46:01 UTC
I tested the font from the link on my Ubuntu machine. It seems to work in Firefox Aurora 16, although I suspect that the rendering is not perfect. It doesn't seem to work in Chromium at all. I reported an upstream bug: https://code.google.com/p/chromium/issues/detail?id=144135 .

It does work in Firefox, Chrome and IE on Windows XP.
Comment 3 bennylin 2012-08-26 01:16:47 UTC
The community have accepted  the proposal:

http://jv.wikipedia.org/wiki/Dhiskusi:Kaca_Utama#Usul:_pasang_font_Jawa_ing_Wikipedia_Basa_Jawa
Comment 4 bennylin 2012-08-31 13:56:12 UTC
(In reply to comment #2)
> I tested the font from the link on my Ubuntu machine. It seems to work in
> Firefox Aurora 16, although I suspect that the rendering is not perfect. It
> doesn't seem to work in Chromium at all. I reported an upstream bug:
> https://code.google.com/p/chromium/issues/detail?id=144135 .
> 
> It does work in Firefox, Chrome and IE on Windows XP.

Can you confirm that the sample text in http://jv.wikipedia.org/wiki/Cithakan:J looks like http://jv.wikipedia.org/wiki/Gambar:Ajisaka.jpg? Because unfortunately only Firefox support Graphite (smart) rendering. I tried Chrome 21 and IE 9 on Windows 7 and it didn't show up properly (the vowels didn't set up properly, and the text without font family enclosing it shows as mojibake).

Firefox (11 and above) users also need to change the config first to see it rendered properly (about:config, then change gfx.font_rendering.graphite.enabled to true). This is due to the complexity of Javanese script is still not supported by OpenType/Uniscribe (more about this on https://sites.google.com/site/jawaunicode/main-page).

Even with all that obstacles, several users have tested it and agreed to install WebFont to Javanese Wikipedia
http://jv.wikipedia.org/wiki/Dhiskusi:Kaca_Utama#Usul:_pasang_font_Jawa_ing_Wikipedia_Basa_Jawa
Comment 5 bennylin 2012-08-31 14:08:40 UTC
Created attachment 11044 [details]
correct rendering using Firefox with graphite enabled

correct rendering of the page http://jv.wikipedia.org/wiki/Cithakan:J
Comment 6 bennylin 2012-08-31 14:10:22 UTC
Created attachment 11045 [details]
wrong rendering using Chrome (and IE)

wrong rendering of the page http://jv.wikipedia.org/w/index.php?title=Cithakan:J

The bottom part still shows correctly because it's an image http://jv.wikipedia.org/wiki/Gambar:Ajisaka.jpg
Comment 7 Amir E. Aharoni 2012-08-31 14:22:04 UTC
Confirmed, looks good in Firefox on Linux after enabling Graphite in about:config.
Comment 8 bennylin 2012-09-01 10:48:28 UTC
(In reply to comment #0)
> Hi, I'm requesting to activate WebFonts for Javanese script in Javanese
> Wikipedia.
> 
> The font can be obtained in:
> 
> http://sites.google.com/site/jawaunicode/download
> http://en.wikipedia.org/wiki/Help:Multilingual_support#Javanese
> 
> A discussion is currently being held at
> http://jv.wikipedia.org/wiki/Dhiskusi:Kaca_Utama and I will update the bug
> after a week or so.

I'm extending the request for all Javanese project: jv.wp, jv.wkt, jv.wb, and map-bms.wp since a Narayam extension is currently being worked on and making it possible to write the script using standard keyboard. Thanks.
Comment 9 bennylin 2012-09-18 16:10:40 UTC
Any update on this bug?
Comment 10 Srikanth Logic 2012-09-20 02:10:42 UTC
Added in https://gerrit.wikimedia.org/r/#/c/24403
Comment 11 Dereckson 2012-11-27 00:38:16 UTC
(In reply to comment #9)
> Any update on this bug?
We have to fix the configuration and we'll be able to update WebFonts.
Comment 12 bennylin 2012-12-06 13:02:46 UTC
It seems that Translatewiki has deployed the latest Narayam that enable Javanese input method. What's missing is the ability to _display_ it using this extension.
Comment 13 Siebrand Mazeland 2012-12-17 07:53:54 UTC
Resetting assignee.
Comment 14 bennylin 2012-12-20 11:11:44 UTC
Any update on this bug?
Comment 15 Dereckson 2012-12-20 13:50:21 UTC
No, the Chrome bug is still unanswered, and there is no solution offered in IE.

To better understand the issue, I would recommend this security review about Graphite:
https://wiki.mozilla.org/Security/Reviews/Firefox/Graphite#Introduce_Feature

Here the relevant feature summary:

"[S]mart font / font shaping technology; similiarity to opentype 
- key diff: opentype assumption is a piece of code somewhere understands the rules of the script and layout to render properly
- this is especially true of asian script type fonts
- opentype does not have all that is needed for these script type languages, thus support for font designers is limited
- instead of getting additions to the OS to support a font, graphite can support it at an application level to support the font/language"

So, to have a good Javanese support, what would be needed:

- Chrome implements Graphite engine or adds Javanese script support.
- Firefox enables Graphite engine by default.
- IE/Windows (I don't know at what level this is precisely done) adds support for Javanese script and layout rules.

To enable it by default, it would seem reasonable for me we would need support in two of the three browsers -or- demonstrated evidence the Javanese visitors use at 75%+ one browser.

Meanwhile, to enable it, turned off by default, would be acceptable.
Comment 16 Dereckson 2012-12-20 14:45:37 UTC
Okay, I prepared the config change (note we first need the WebFonts work to be merged). Gerrit change #39578.
Comment 17 Dereckson 2012-12-20 21:05:22 UTC
Nikerabbit indicates the next i18n deployment window will be next year.

This means this could be enabled 2013-01-02 or 2013-01-09.
Comment 18 Dereckson 2012-12-22 18:36:42 UTC
Gerrit change #39572 has been merged, so we can now enable on a wiki the WebFonts extension, but disabled by default.
Comment 19 bennylin 2012-12-23 04:36:06 UTC
Thanks a lot. Resolved as fixed.
Comment 20 bennylin 2012-12-23 04:53:26 UTC
Edit: I'm creating separate bug for the activation since the title and thus the scope of the bug was changed  from: "Enable WebFonts on the Javanese Wikipedia (jvwiki)" to "Add Javanese font to WebFonts"

See bugzilla:43359 for the new request.
Comment 21 Dereckson 2012-12-23 14:59:38 UTC
I'm reopening this bug.

What has been merged is a configuration parameter to have the WebFonts extension but disabled by default.

Gerrit change #24403 should still be merged to solve this bug.
Comment 22 Santhosh Thottingal 2013-03-22 10:44:40 UTC
Gerrit change #24403 merged, It was also ported to ULS in https://gerrit.wikimedia.org/r/53599


That also merged.
Comment 23 bennylin 2013-03-22 14:13:49 UTC
Thanks!
Comment 24 bennylin 2014-10-05 06:48:07 UTC
Sorry to reopen this again, but the font is not loading anymore. Thus we are requesting the font to be available again in Javanese projects
Comment 25 Andre Klapper 2014-10-27 11:57:29 UTC
(In reply to bennylin from comment #24)
> Sorry to reopen this again, but the font is not loading anymore. Thus we are
> requesting the font to be available again in Javanese projects

The WebFonts extension is dead and not in use anymore. 
If there is a new issue after 18 months, please file a new bug report against the "UniversalLanguageSelector" component with exact steps to reproduce (and URL, browser, etc.). Thank you!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links