Last modified: 2012-09-05 23:01:09 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 39288 - No RTL Styling support in the WLM app
No RTL Styling support in the WLM app
Status: RESOLVED FIXED
Product: WikiLoves Monuments Mobile
Classification: Unclassified
General (Other open bugs)
unspecified
All All
: High normal
: ---
Assigned To: Nobody - You can work on this!
: i18n
: 39858 39861 39863 (view as bug list)
Depends on: 39858 39861 39863
Blocks: rtl
  Show dependency treegraph
 
Reported: 2012-08-12 19:07 UTC by Amir E. Aharoni
Modified: 2012-09-05 23:01 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Amir E. Aharoni 2012-08-12 19:07:52 UTC
I tried a custom build of the WLM app that Yuvi prepared for me. It incorporates https://github.com/wikimedia/WLMMobile/pull/101/ , which is not merged yet, so that non-English languages would appear.

It doesn't look like the app has any RTL support at all. The Hebrew strings appear, but they are not aligned correctly.
Comment 1 Amir E. Aharoni 2012-08-16 16:36:59 UTC
Thank you, Yuvi, for fixing most of this.

The biggest issue that I see now is the way that the arrows at the top of screen point.
Comment 2 Jon 2012-08-27 17:50:33 UTC
Things that need to be done:
* Create script that given a css file spits out a new css file which supports RTL (https://code.google.com/p/cssjanus/ may help)
* Based on user agent select the correct stylesheet and adds it dynamically. Note we may want to choose between a ltr.css and rtl.css or just conditionally add a css file with the diff of the 2 stylesheets
Comment 3 Arthur Richards 2012-08-29 19:19:52 UTC
After triage conversation, lowering priority. While there is no RTL view of the app, strings are still readable and functional.
Comment 4 Amir E. Aharoni 2012-08-31 21:08:55 UTC
Bumping back. I'm going to report a few bugs where the strings are totally unreadable.
Comment 5 Jon 2012-08-31 23:20:03 UTC
*** Bug 39863 has been marked as a duplicate of this bug. ***
Comment 6 Jon 2012-08-31 23:26:07 UTC
*** Bug 39861 has been marked as a duplicate of this bug. ***
Comment 7 Jon 2012-08-31 23:26:12 UTC
*** Bug 39858 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links