Last modified: 2013-12-05 10:11:01 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 38763 - Our *.wikimedia.org cert doesn't properly cover https://pa.us.wikimedia.org/
Our *.wikimedia.org cert doesn't properly cover https://pa.us.wikimedia.org/
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
SSL related (Other open bugs)
unspecified
All All
: Low trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
: ops
Depends on:
Blocks: wikis-to-rename 31335
  Show dependency treegraph
 
Reported: 2012-07-27 18:05 UTC by James Forrester
Modified: 2013-12-05 10:11 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description James Forrester 2012-07-27 18:05:23 UTC
Though pauswikimediawiki is 'somewhat' dead, it should either be renamed or we should find a solution to the SSL cert failure.
Comment 1 Platonides 2012-07-27 18:09:22 UTC
It doesn't include *.m.wikimedia.org either, so both entries can be added when requesting a new certificate.
Comment 2 Ruslan 2012-08-07 19:32:56 UTC
*.planet.wikimedia.org is also problematic.
Comment 3 Daniel Zahn 2012-09-25 22:34:06 UTC
for *.planet.wikimedia.org -> RT #3481
Comment 4 Daniel Zahn 2012-12-21 18:56:33 UTC
we would prefer renaming of sub.sub.domains. It is not possible to get a *.*.wikimedia.org cert as far as we know. So we would have to get extra certificates or add them as additional SANs. Please also hear RobH on this, since he orders certs and had some plans to get them unified.
Comment 5 Daniel Zahn 2013-01-25 23:48:40 UTC
What would you think of using wikimedia.us as the TLD for all US-based city/state chapters?

".., like us-bo Wikimedia Boston,  us-ca Wikimedia California, us-mw Wikimedia Midwest US and us-pa Wikimedia Pennsylvania and turn those into bo.wikimedia.us, ca.wikimedia.us, bo.wikimedia.us"

https://rt.wikimedia.org/Ticket/Display.html?id=4416
Comment 6 MZMcBride 2013-02-11 08:36:26 UTC
This bug appears to be a duplicate of bug 31335.
Comment 7 Daniel Zahn 2013-03-14 21:02:46 UTC
added pa-us.wikimedia.org to DNS to replace pa.us (but keep that too for redirects
Comment 8 Sam Reed (reedy) 2013-03-14 22:42:40 UTC
RENAMED


O
M
G
Z
Comment 9 Daniel Zahn 2013-03-14 22:45:41 UTC
https://gerrit.wikimedia.org/r/#/c/53874/
https://gerrit.wikimedia.org/r/#/c/53859/

apache-fast-test pa-us.wikimedia.url mw1044 testing 4 urls on 1 servers, totalling 4 requests spawning threads..

http://pa-us.wikimedia.org
* 301 Moved Permanently http://pa-us.wikimedia.org/wiki/Main_Page
http://pa.us.wikimedia.org
* 301 Moved Permanently https://pa-us.wikimedia.org/
https://pa-us.wikimedia.org
* 301 Moved Permanently https://pa-us.wikimedia.org/wiki/Main_Page
https://pa.us.wikimedia.org
* 301 Moved Permanently https://pa-us.wikimedia.org/
Comment 10 Daniel Zahn 2013-03-14 22:46:09 UTC
15:52 < mutante> !log pa.us.wikimedia.org now redirects to pa-us.wikimedia.org (Wikimedia Pennsylvania) (no sub.sub domains)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links