Last modified: 2014-01-13 17:31:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 38661 - CSS class reference-text missing when reference starts with a table
CSS class reference-text missing when reference starts with a table
Status: RESOLVED DUPLICATE of bug 47544
Product: MediaWiki extensions
Classification: Unclassified
Cite (Other open bugs)
unspecified
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 07:37 UTC by Michael M.
Modified: 2014-01-13 17:31 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Michael M. 2012-07-25 07:37:07 UTC
My first guess is that Tidy is the culprit. Try the input

<ref>foo</ref><ref><div>bar</div></ref><ref><table><tr><td>baz</td></tr></table></ref>
<references />

on Wikipedia.
The first reference is correctly wrapped in a <span class="reference-text">, in the second reference this span is moved inside the <div>, in the third it is missing completely.
Comment 1 Derk-Jan Hartman 2012-07-25 07:52:32 UTC
You are putting HTML block elements into inline elements. Tidy is rightfully cleaning up.
Comment 2 TMg 2014-01-13 17:31:37 UTC
Marking bug 38661 as a duplicate of the more specific and more commented bug 47544. Whats described here is an effect of the bad HTML nesting described in bug 47544.

*** This bug has been marked as a duplicate of bug 47544 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links