Last modified: 2010-05-15 15:37:56 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 3842 - install hangs after initialising "mediawiki" namespace
install hangs after initialising "mediawiki" namespace
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2005-10-31 00:57 UTC by michele pan
Modified: 2010-05-15 15:37 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description michele pan 2005-10-31 00:57:37 UTC
New to mediawiki so I'm hoping someone can help...

Install basically hangs after the message 'initialising "mediawiki"
namespace...'; no localsettings.php file is written to the config directory.
I've tried reinstalling and the same thing happens. 

Checking environment...

    * PHP 5.0.5: ok
    * Warning: PHP's register_globals option is enabled. MediaWiki will work
correctly, but this setting increases your exposure to potential security
vulnerabilities in PHP-based software running on your server. You should disable
it if you are able.
    * PHP server API is cgi; using ugly URLs (index.php?title=Page_Title)
    * Have XML / Latin1-UTF-8 conversion support.
    * PHP is configured with no memory_limit.
    * Have zlib support; enabling output compression.
    * Neither Turck MMCache nor eAccelerator are installed, can't use object
caching functions
    * GNU diff3 not found.
    * Found GD graphics library built-in, image thumbnailing will be enabled if
you enable uploads.
    * Installation directory: /mnt/web_f/d36/s11/b0260509/www/wiki
    * Script URI path: /wiki
    * PHP is linked with old MySQL client libraries. If you are using a MySQL
4.1 server and have problems connecting to the database, see for help.
    * Trying to connect to MySQL on wiki as root...
          o MySQL error 1045: Access denied for user 'root'@'' (using
password: NO)
    * Trying regular user... ok.
    * Connected to 4.1.12-log; enabling MySQL 4 enhancements; You are using
MySQL 4.1 server, but PHP is linked to old client libraries; if you have trouble
with authentication, see for help.
    * Database d60180731 exists
    * There are already MediaWiki tables in this database. Checking if updates
are needed...

...hitcounter table already exists.
...querycache table already exists.
...objectcache table already exists.
...categorylinks table already exists.
...logging table already exists.
...validate table already exists.
...user_newtalk table already exists.
...transcache table already exists.
...trackbacks table already exists.
...have ipb_id field in ipblocks table.
...have ipb_expiry field in ipblocks table.
...have rc_type field in recentchanges table.
...have rc_ip field in recentchanges table.
...have rc_id field in recentchanges table.
...have rc_patrolled field in recentchanges table.
...have user_real_name field in user table.
...have user_token field in user table.
...have user_email_token field in user table.
...have log_params field in logging table.
...have ar_rev_id field in archive table.
...have ar_text_id field in archive table.
...have page_len field in page table.
...have rev_deleted field in revision table.
...have img_width field in image table.
...have img_metadata field in image table.
...have img_media_type field in image table.
...have val_ip field in validate table.
...have ss_total_pages field in site_stats table.
...have iw_trans field in interwiki table.
...already have interwiki table
...indexes seem up to 20031107 standards
Already have pagelinks; skipping old links table updates.
...image primary key already set.
The watchlist table is already set up for email notification.
...user table does not contain old email authentication field.
Logging table has correct title encoding. table already exists.
revision timestamp indexes already up to 2005-03-13
...rev_text_id already in place.
...page_namespace is already a full int (int(11)).
...ar_namespace is already a full int (int(11)).
...rc_namespace is already a full int (int(11)).
...wl_namespace is already a full int (int(11)).
...qc_namespace is already a full int (int(11)).
...log_namespace is already a full int (int(11)).
...already have pagelinks table.
No img_type field in image table; Good.
Already have unique user_name index.
...user_groups table already exists.
...user_groups is in current format.
Initialising "MediaWiki" namespace...
Comment 1 Brion Vibber 2005-10-31 00:58:48 UTC
This step may take a minute or two. Are you letting it run?
Comment 2 michele pan 2005-10-31 02:05:52 UTC
Yes...still no joy. 
Comment 3 Rob Church 2005-12-15 19:51:40 UTC
As with the follow up for a while...going to assume resolved,
abandoned or help sought elsewhere.

Note You need to log in before you can comment on or make changes to this bug.