Last modified: 2012-10-03 16:42:51 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 38196 - Set up https://github.com/mediawiki/core mirror
Set up https://github.com/mediawiki/core mirror
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Git/Gerrit (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on: 35429
Blocks: 35497
  Show dependency treegraph
 
Reported: 2012-07-05 10:34 UTC by Krinkle
Modified: 2012-10-03 16:42 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Krinkle 2012-07-05 10:34:31 UTC
Branching off from bug 35497, which is about setting up an easy-as-possible pull-request link to Gerrit once the mirror is set up
Comment 1 Krinkle 2012-07-05 10:35:05 UTC
(Cite bug 35497 comment #13)
> So, some ideas:
> 
> * Don't use github.com/mediawiki/core as name
>  - means we duplicate user groups/rights with the org "Wikimania" at github
>  - means we're going to promote ourselves as "core". e.g.
> github.com/Krinkle/core.
>  - any advantages?
>   hashar mentioned we want to be able to allow volunteers to help out with the
> handling of pull-request and that to grant them rights we'd want to have it
> outside the @wikimedia organization. However this is not needed because:
>    * github allows collaboration without any rights at all. You can leave
> inline comments, and stuff on any pull request anywhere
>    * as in comment 12, they are pull-able in many different formats including
> plain "git pull" so anyone can pull it locally, and if they have a labs ldap
> account they can also push straight to gerrit for review.
>    * github supports auto-closing of pull-requests when the commit hash is
> pushed into the repo, so no maintenance there either. And if the commit has to
> be amended, including "fixes GH-123" or "closes GH-123" will also close the
> relevant PR as soon as it is merged. And if all else fails, a repo collab in
> @wikimedia (of which there are many[1]) can just push "Close" manually on
> github
>      So volunteers have complete access without needing to be manually added to
> anything, this is what made GitHub works. And if its only about closing some
> exceptional ones, then I'm sure we'll manage that.
> 
> * Use github.com/wikimedia/mediawiki-core
>  - ideally we'd have some kind of auto-push from gerrit or jenkins, otherwise
> just set up a 30 minute cron somewhere to `pull gerrit -f` and `push github
> -f`.
>  - admin settings: pull-request: true, issues: false, wiki: false
> 
> [1] https://github.com/wikimedia
Comment 2 Chad H. 2012-07-05 10:38:27 UTC
How is this not a duplicate of bug 35429? I'll be doing all the repos at once when I setup replication, not one-by-one.
Comment 3 Krinkle 2012-07-05 10:44:23 UTC
(In reply to comment #2)
> How is this not a duplicate of bug 35429? I'll be doing all the repos at once
> when I setup replication, not one-by-one.

I didn't say it wasn't a dupe. But since it appears there is no clarity yet on how the gerrit or jenkins replication is going, I figured we may be able to set up at least something on the short term for mediawiki-core so that its out there and we can start experimenting with how to solve other issues such as what and if we need a tool for pulling in pull-requests (or that git pull github.com...; git push gerrit HEAD:refs/for/master/gh-123/some-feature; is sufficient).

I mean.. I could just ask for the repo and set a cron up to mirror and get it going. Seems low hanging fruit. But if bug 35429 can be done within say 2 weeks, then by all means dupe it.
Comment 4 Chad H. 2012-10-03 16:28:19 UTC
Github replication for core is now in place: https://github.com/mediawiki/core

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links