Last modified: 2014-03-05 18:46:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 37084 - WikiEditor: Toolbar should insert tags in edit summary input (if focussed)
WikiEditor: Toolbar should insert tags in edit summary input (if focussed)
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
WikiEditor (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: javascript
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 12:48 UTC by Helder
Modified: 2014-03-05 18:46 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Helder 2012-05-24 12:48:38 UTC
1) Open a page in 'edit' mode
2) Click in the summary field
3) Click in the "Link" button of the (enhanced) toolbar
4) Fill the fields "Target page or URL:" and "Text to display:" with some random text (e.g. "foo" and "bar")
5) Click on "Insert link"

Actual result:
* The text "[[foo|bar]]" will be added to the edit box

Expected result:
* The text "[[foo|bar]]" should be added to the summary field (i.e. the one with focus when the button is clicked)

The same happens with other buttons (although they are not that useful for a summary) but works fine with the old toolbar (wich inserts "[[Link title]]" in the summary).
Comment 1 Helder 2012-10-03 22:19:08 UTC
*** Bug 39268 has been marked as a duplicate of this bug. ***
Comment 2 Krinkle 2012-10-04 20:30:16 UTC
This legacy toolbar actually had this feature (it bound to all input,textarea on the page, and kept a reference to the one focussed most recently).

Though we could re-create that feature in WikiEditor, I think it was by design that WikiEditor doesn't have it:
* The toolbar is bound to a specific textarea for a reason, namely because it is positions right on top of it (clicking a button on top of area A should focus area A and insert a button into it).
* There can be multiple WikiEditor areas on one page, so if it would do this, stuff will break even worse.
* And lastly, edit summaries shouldn't contain wikitext in the first place (though that on its own is arguable).

As such marking as wontfix because in the current design this is not possible, and I think that design is for a good reason.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links