Last modified: 2012-05-13 11:38:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 36803 - properly display characters with directionality neutral if uselang=foobar is using the opposite directionality
properly display characters with directionality neutral if uselang=foobar is ...
Status: RESOLVED DUPLICATE of bug 32403
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://he.wikipedia.org/?curid=172045...
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2012-05-13 04:19 UTC by lɛʁi לערי ריינהארט
Modified: 2012-05-13 11:38 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description lɛʁi לערי ריינהארט 2012-05-13 04:19:37 UTC
complete bug summary: "properly display characters with directionality neutral if uselang=foobar is using the opposite directionality "then the wiki***"

Hi! The complete bug report is written at a live wiki:
http://en.wikipedia.org/?oldid=492307285#bugzilla

the test url is
http://he.wikipedia.org/?curid=172045&uselang=en

explanations: the page [[he:אהרון נימצוביץ']] has as last title character an apostrophe. In the actual bugzilla LTR environment and also when "uselang=foobar" is used where foobar is a language using a LTR script the apostrophe at the end of the title is represented rightmost while you may look at / read the article text and will see the apostrophe leftmost.

It should be possible to fix such BiDirectional issues using proper "span" / "div" etc. embedding. Please avoid the usage of BiDirectional characters.

Best regards Reinhardt

P.S. this bug blocks Bug 749. I was not here for a long ime. Please set the proper values of whatever required field.
Comment 1 Amir E. Aharoni 2012-05-13 04:24:08 UTC

*** This bug has been marked as a duplicate of bug 32403 ***
Comment 2 lɛʁi לערי ריינהארט 2012-05-13 11:38:13 UTC
(In reply to comment #0)
> Hi! The complete bug report is written at a live wiki:
> http://en.wikipedia.org/?oldid=492307285#bugzilla

There have been severe syntax errors; it should have been corrected at
http://en.wikipedia.org/?oldid=492347485#bugzilla:36803 .

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links