Last modified: 2013-04-02 11:26:26 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 34982 - Enable WebFonts on all WMF projects
Enable WebFonts on all WMF projects
Status: RESOLVED DUPLICATE of bug 13097
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Lowest enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
: i18n
Depends on: 35426
Blocks: 34159 34550 34700 34817
  Show dependency treegraph
 
Reported: 2012-03-05 10:34 UTC by Raimond Spekking
Modified: 2013-04-02 11:26 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Raimond Spekking 2012-03-05 10:34:53 UTC
Currently WebFonts are enabled on some wikis only.

But I think that all projects can benefit from WebFonts, i.e. pages like https://en.wikipedia.org/wiki/Akkadian_cuneiform#Syllabary and https://en.wiktionary.org/wiki/%F0%92%80%80

Compare with https://translatewiki.net/wiki/User:Raymond/Akkadian where Cuneiform/Akkadian characters looks very good.
Comment 1 Alex Monk 2012-07-24 21:02:49 UTC
Does this change need global community consensus?
Currently the config has commented out enable entries with "# XXX probably shouldn't be included". Should these wikis be excluded?
Comment 2 Amir E. Aharoni 2012-07-24 21:27:34 UTC
I very much want to enable it everywhere, but I also know that in the current state of the extension, there will be at least three languages that won't like it, and maybe more than three. One of them is Hebrew, the font for which is useful for testing, but not so much for reading; I'm working on improving that (a pet project of sorts).

As for the others, either better fonts are needed, or a more clever way to disable experimental fonts.

So it's a bit early for Wikimedia-wide deployment, but we are certainly working toward that.
Comment 3 Alex Monk 2012-07-24 21:29:30 UTC
RESOLVED LATER in that case.
Comment 4 Nemo 2012-11-14 12:17:38 UTC
Switching from LATER to the second most relevant resolution for fear of information loss. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/65116
(No other resolution is actually correct, but Site requests without shell keyword are meant to be waiting on something.)
Comment 5 bennylin 2012-12-23 04:53:44 UTC
See also: bugzilla:43297 (Allow WebFonts to be loaded but disabled by default.)
Comment 6 Andre Klapper 2012-12-31 11:14:51 UTC
[Adding bug 43297 to the "See Also" field.]
Comment 7 Nemo 2013-04-02 09:58:00 UTC
(In reply to comment #4)
> Switching from LATER to the second most relevant resolution

WebFonts is legacy; this will be done only as part of ULS, from what I understand.

*** This bug has been marked as a duplicate of bug 13097 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links