Last modified: 2012-12-08 08:58:10 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 34980 - [Regression] IRC action text should never contain HTML for title
[Regression] IRC action text should never contain HTML for title
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CentralAuth (Other open bugs)
unspecified
All All
: Normal critical (vote)
: MW 1.19 version
Assigned To: Alexandre Emsenhuber [IAlex]
:
Depends on:
Blocks: 16599 31217
  Show dependency treegraph
 
Reported: 2012-03-05 00:07 UTC by Krinkle
Modified: 2012-12-08 08:58 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Krinkle 2012-03-05 00:07:37 UTC
Although bug 34508 was fixed and many actions have been hardcoded to be fixed, there is still an issue with log actions registered by extensions.

However it's a different bug than bug 34508. The problem is not the format of the message. Wether the i18n message key is the same or not is not in the question here.

The problem is that the logging system is replacing variables with an HTML link instead of a bracketed wiki link for the target title.

Reporting in core instead of CentralAuth since this should be fixed centrally, not by hardcoding an exception for centralauth.


<rc-pmtpa> [[Special:Log/gblrights]] setchange  * Dungodung *  changed wikis in "<a href="/wiki/Special:WikiSets/12" title="Special:WikiSets/12">All existing wikis</a>": added: (none); removed: chwikimedia: -chwikimedia
Comment 1 Alexandre Emsenhuber [IAlex] 2012-03-19 16:43:41 UTC
Fixed in r114151; this was a regression from r106782 (last chunk of CentralAuth.php). Core behaviour did not change, so I'm putting this bug back in MediaWiki extensions/CentralAuth.
Comment 2 Nemo 2012-12-08 08:56:07 UTC
*** Bug 42851 has been marked as a duplicate of this bug. ***
Comment 3 Nemo 2012-12-08 08:58:10 UTC
(In reply to comment #0)
> Reporting in core instead of CentralAuth since this should be fixed
> centrally,
> not by hardcoding an exception for centralauth.

Is this still valid? If yes, it should be reopened because there are other instances like bug 42851.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links