Last modified: 2012-10-04 09:53:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 32826 - Titles in indic languages are partially cut
Titles in indic languages are partially cut
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Santhosh Thottingal
: i18n
: 33131 33148 (view as bug list)
Depends on:
Blocks: 40760
  Show dependency treegraph
 
Reported: 2011-12-06 16:23 UTC by Santhosh Thottingal
Modified: 2012-10-04 09:53 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Title Bar getting cut in knwp (91.97 KB, image/png)
2012-03-19 07:05 UTC, Srikanth Logic
Details

Description Santhosh Thottingal 2011-12-06 16:23:54 UTC
Bug 30809  and Bug 29405 are applicable for Many more Indic languages.  Indian languages requires line hight  a bit bigger than latin languages, because the stacked , below/over base matra signs etc. The Hindi issue was addressed in r99389 and later fixed for Assamese Bengali, Hindi, Malayalam , Odiya in r104160

But this fix should be done for other supported languages too.
Comment 1 Santhosh Thottingal 2011-12-08 06:32:54 UTC
r105517 addressed this for as, bn, gu, hi, kn, ml, mr, or, pa, sa, ta, te languages
Comment 2 Santhosh Thottingal 2011-12-15 09:27:04 UTC
*** Bug 33148 has been marked as a duplicate of this bug. ***
Comment 3 Santhosh Thottingal 2011-12-15 09:32:37 UTC
*** Bug 33131 has been marked as a duplicate of this bug. ***
Comment 4 Srikanth Logic 2012-03-19 05:42:08 UTC
I thought this fix was pushed along 1.19 seeing the release notes http://svn.wikimedia.org/viewvc/mediawiki/branches/REL1_19/phase3/RELEASE-NOTES-1.19?view=markup . Is this deployed and I am still seeing the issue?
Comment 5 Siebrand Mazeland 2012-03-19 05:47:17 UTC
(In reply to comment #4)
> Is this deployed and I am still seeing the issue?

Can you please provide clearer input. Preferably in the form of specific cases in which you observe that presentation differs from your expectation. If you observe that the issue has been resolved, please close it.
Comment 6 Srikanth Logic 2012-03-19 07:05:49 UTC
Created attachment 10264 [details]
Title Bar getting cut in knwp

(In reply to comment #5)
> (In reply to comment #4)
> > Is this deployed and I am still seeing the issue?
> 
> Can you please provide clearer input. Preferably in the form of specific cases
> in which you observe that presentation differs from your expectation. If you
> observe that the issue has been resolved, please close it.

I have attached the page what I get. The upper part of the title is cut. I remember seeing this issue addressed in http://kn.wikipedia.beta.wmflabs.org/ but cant confirm now since its down. This was on Ubuntu / Chrome. I dont see this on Win XP + Firefox 

Am seeing an even more critical issue with WebFonts(possibly due to Lohit 2.5.1 ?) on WinXP + Chrome. Logging that in few minutes, or may be both could be related.
Comment 7 Srikanth Logic 2012-03-19 07:08:02 UTC
Marking browser as chrome, since I cant reproduce it on IE / FF
Comment 8 Santhosh Thottingal 2012-03-22 15:18:19 UTC
Srikanth, can you confirm this by using Kannada interface? the css rules for line height are language specific
Comment 9 Srikanth Logic 2012-03-22 15:44:15 UTC
(In reply to comment #8)
> Srikanth, can you confirm this by using Kannada interface? the css rules for
> line height are language specific

So yes, works for me on kn interface. But should this check be on the language of wiki / language of the page instead of interface language of the user?

Removing chrome since its was observed on Firefox / Chromium after using en interface.
Comment 10 Santhosh Thottingal 2012-03-22 17:05:41 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Srikanth, can you confirm this by using Kannada interface? the css rules for
> > line height are language specific
> 
> So yes, works for me on kn interface. But should this check be on the language
> of wiki / language of the page instead of interface language of the user?

Can you share the URL of that page? If there is any parent node with lang=kn the rules will apply. But looking at similar pages as in screenshot, I see it is only 'en'. If there is a way to tell that first heading is in language kn, the language specific rules will make bigger line height.
Comment 11 Santhosh Thottingal 2012-03-22 17:49:44 UTC
As srikanth confirmed in the IRC, the case comes only when page language, or parent nodes or the node itself has no information about language or it is en(user interface language). So it is an issue of not having sufficient and correct language attributes. 
If any node is marked with kn, the fix did for this bug get applied.
So closing this bug.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links