Last modified: 2012-06-16 02:45:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 31608 - API edit support for reCAPTCHA
API edit support for reCAPTCHA
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
ConfirmEdit (CAPTCHA extension) (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: patch, patch-need-review
Depends on:
Blocks: noncoreapi
  Show dependency treegraph
 
Reported: 2011-10-11 13:14 UTC by Nikola Kovacs
Modified: 2012-06-16 02:45 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
add api edit support (2.96 KB, patch)
2011-10-11 13:28 UTC, Nikola Kovacs
Details

Description Nikola Kovacs 2011-10-11 13:14:48 UTC
ReCaptcha doesn't implement addCaptchaAPI, so it falls back to SimpleCaptcha, but then it still calls reCAPTCHA's passCaptcha function, so it's impossible to edit via api if the captcha is set to reCAPTCHA.
Comment 1 Nikola Kovacs 2011-10-11 13:28:23 UTC
Created attachment 9216 [details]
add api edit support

This patch implements addCaptchaAPI and removes ConfirmEdit, since it's unnecessary - it seems it was reimplemented in ReCaptcha to detect when the captcha had to be shown for the first time and not show an error message, but a minor change to passCaptcha ( if ( $response === null ) { return false; } ) accomplishes that.

Because the api edit module sets wpCaptchaId and wpCaptchaWord, those are passed to recaptcha as recaptcha_challenge_field and recaptcha_response_field if the latter two are not set. The api returns only the public key and the error message - the client can use this to ask the recaptcha server for a captcha, it works in javascript at least.
Comment 2 Sumana Harihareswara 2012-05-16 19:37:48 UTC
Nikola, would you be interested in using https://www.mediawiki.org/wiki/Developer_access developer access to submit this patch directly into Gerrit?
Comment 3 Brad Jorsch 2012-06-16 02:45:47 UTC
Closing, as this patch seems to have been applied in r104875.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links