Last modified: 2011-12-14 17:37:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 31136 - suggestion for magic words
suggestion for magic words
Status: RESOLVED DUPLICATE of bug 6455
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-24 15:27 UTC by reza1615
Modified: 2011-12-14 17:37 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description reza1615 2011-09-24 15:27:24 UTC
Hi,
Is it possilble to add these functions to media wiki?

1-len(string) for calculation of string length
2-Mid(string) like {{padright:}} or {{padright:}}
3-split()
4-strip()
5-.find()

thank you
Comment 1 MZMcBride 2011-09-24 15:31:54 UTC
I believe most of this functionality is already available in the StringFunctions module of the ParserFunctions extension.

* http://www.mediawiki.org/wiki/Extension:StringFunctions
* http://www.mediawiki.org/wiki/Extension:ParserFunctions
Comment 2 Mark A. Hershberger 2011-09-24 18:02:19 UTC

*** This bug has been marked as a duplicate of bug 6455 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links