Last modified: 2014-06-05 09:16:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 30555 - Implement a sane push interface for recent changes
Implement a sane push interface for recent changes
Status: RESOLVED DUPLICATE of bug 14045
Product: MediaWiki
Classification: Unclassified
Recent changes (Other open bugs)
unspecified
All All
: Low enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 29305
  Show dependency treegraph
 
Reported: 2011-08-24 18:39 UTC by Krinkle
Modified: 2014-06-05 09:16 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Krinkle 2011-08-24 18:39:29 UTC
Right now MediaWiki comes with a string-based recent changes push system which sends UDP packets on-change (just like DB-rows are inserted into the recentchanges-table).

The problem with this is that it's just a string that isn't very machine readable. And the actual text is localized which makes it even harder.

For example, right now if a bot wants to get push notifications for certain log actions (ie. block or delete), the bot has to download the MediaWiki-namespace messages, convert them to regexes and then whenever a "change" to Special:Log/.... is made, the text is matched against each of the regexes and eventually we can find our out if the action was 'protect' or 'unprotect' or 'modifyprotect' etc.

A better solution would be to send JSON or XML, which is much easier to parse. This opens an incredible amount of possibilities for developers. For example, one could create a "real-time wiki monitor" with dropdown menu's for filters. Eg. Users: Anonymous / Logged-in / Both. Right now this would require parsing the username from the rc-feed and checking if it matches MW's IPv4 or IPv6 regex. In the future there could could simply be a boolean anon="" segment (like the API already has). Another major problem in the current system is user group member. (currently requires making an API request to get a list of admins/bots/<othergroup> and keeping them in memory and doing a look-up on every single change.

This bug requests such a push system to be implemented in core (just like we have for string-packets to UDP). Another MW-extension, LocalSettings config or independent server-side service would then listen to that and potentially provide stuff like PubSubHubHub, WebSockets, Jabber etc.)

Dependencies on this bug are issues and feature requests that would be solved or become an option with this new system.
Comment 1 Roan Kattouw 2011-08-24 21:01:12 UTC
There's Extension:XMLRC. Daniel, how complete is that?
Comment 2 Krinkle 2014-06-05 09:16:33 UTC

*** This bug has been marked as a duplicate of bug 14045 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links