Last modified: 2011-07-19 01:04:27 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 29775 - <ref>...</ref> in template
<ref>...</ref> in template
Status: RESOLVED DUPLICATE of bug 2700
Product: MediaWiki extensions
Classification: Unclassified
Cite (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-08 19:13 UTC by orenbochman
Modified: 2011-07-19 01:04 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description orenbochman 2011-07-08 19:13:18 UTC
within templates contents of ref tags is not expanded e.g. <ref>{{{cite}}}<ref>
will generate a reference is the literal "{{{cite}}}"

This has led to fragile templates based on "tag" templates and makes automation of references impractical.
Comment 1 Brion Vibber 2011-07-08 20:20:42 UTC
{{#tag:ref|bla {{{cite}}} bla}} ought to expand parameters in the way you expect; give it a try and see if that helps.
Comment 2 Roan Kattouw 2011-07-14 23:59:23 UTC
Dupe of bug 2257?
Comment 3 Mark A. Hershberger 2011-07-18 15:52:41 UTC
feels more like bug #2700 to me since bug #2257 is closed.

*** This bug has been marked as a duplicate of bug 2700 ***
Comment 4 orenbochman 2011-07-18 22:42:00 UTC
Brion Vibber & Mark A. Hershberger

Thanks for the work around. 

However it did take me about 5 hours of tinkering to get the template to working properly. Passing an argument is documented inconsistently. And there is both a parser function #tag and a template tag.

Surely we cannot wiki contributors - who will see their articles deleted or censured by academia (for lack of proper citation) - to become parser function hacking ninjas like ... us?

I understand your wish to reduce the number of pending bugs in Bugzilla. I however am not convinced that this is the same as bug 2700. There are issues related to the tag's attributes and to printing that are complicated to detail at this point.

I therefore humbly request you unmark it as a resolved or as a dupe untill it has actually been fixed by the patch for 2700 (not just on a development machine) without resorting to a 5 hour work around. 

Otherwise you are just sweeping the bug under the carpet.

p.s. please advise how to apply the related patch, and if that could have side effects.
Comment 5 Mark A. Hershberger 2011-07-19 01:04:27 UTC
(In reply to comment #4)
 
> I therefore humbly request you unmark it as a resolved or as a dupe untill it
> has actually been fixed by the patch for 2700 (not just on a development
> machine) without resorting to a 5 hour work around. 
> 
> Otherwise you are just sweeping the bug under the carpet.

If it is marked as a dupe and the fix to 2700 doesn't fix the bug, then please reopen the bug.  Marking bugs as duplicates is not sweeping them under the carpet ... it helps us keep track of how important a bug is.

> p.s. please advise how to apply the related patch, and if that could have side
> effects.

The patch supplied on #2700 is not valid.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links