Last modified: 2012-09-27 01:10:52 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 29010 - Vector skin in r88235 seems to be incompatible with IE8/IE9
Vector skin in r88235 seems to be incompatible with IE8/IE9
Status: RESOLVED DUPLICATE of bug 28840
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.17.x
All All
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-16 14:29 UTC by Dmitriy Sintsov
Modified: 2012-09-27 01:10 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
rendering of the site in ff4 (77.07 KB, image/png)
2011-05-18 09:30 UTC, Dmitriy Sintsov
Details
rendering of the site in ie8 (53.86 KB, image/png)
2011-05-18 09:31 UTC, Dmitriy Sintsov
Details
nginx main page load log in ff4 (5.66 KB, text/plain)
2011-05-18 09:32 UTC, Dmitriy Sintsov
Details
nginx main page load log in ie8 (2.96 KB, text/plain)
2011-05-18 09:32 UTC, Dmitriy Sintsov
Details

Description Dmitriy Sintsov 2011-05-16 14:29:12 UTC
Vector works fine in Safari / FF / Opera, looks broken in IE8 / IE9. Switching to Monobook fixes the view in IE8 / IE9. Changing language code from "ru" to "en" does not help. Disabling extensions (SMW, Poem, ParserFunctions, QPoll) also does not help. I checkout from http://svn.wikimedia.org/svnroot/mediawiki/branches/REL1_17/phase3
Comment 1 Sam Reed (reedy) 2011-05-16 14:30:15 UTC
Can you give us a screenshot of the error?
Comment 2 Roan Kattouw 2011-05-16 14:35:41 UTC
(In reply to comment #1)
> Can you give us a screenshot of the error?
And describe what's broken. "It looks broken" is not very useful for a developer investigating the issue.
Comment 3 Dmitriy Sintsov 2011-05-16 14:37:35 UTC
Oops.. now it also does not work in FF / Safari. Seems like an issue with my hosting. I should close this report, sorry. In case something wrong I can re-open it.
Comment 4 Dmitriy Sintsov 2011-05-18 09:29:35 UTC
I am going to temporarily re-enabling this bug. I've switched from apache httpd / mod_php to nginx php-fpm, because I've thought that the troubles due to non-standard apache httpd setup. However with nginx php-fpm I have the same serve: FF4 renderd the site fine, while IE8 / IE9 has broken skin. The site is http://psy.wiki.uniyar.ac.ru/ does it exhibit the same problem at another clients?

I'll attach nginx log of serve from FF4 and from IE8. Also a pictures of visual display in browsers.
Comment 5 Dmitriy Sintsov 2011-05-18 09:30:17 UTC
Created attachment 8548 [details]
rendering of the site in ff4
Comment 6 Dmitriy Sintsov 2011-05-18 09:31:08 UTC
Created attachment 8549 [details]
rendering of the site in ie8
Comment 7 Dmitriy Sintsov 2011-05-18 09:32:20 UTC
Created attachment 8550 [details]
nginx main page load log in ff4
Comment 8 Dmitriy Sintsov 2011-05-18 09:32:56 UTC
Created attachment 8551 [details]
nginx main page load log in ie8
Comment 9 Dmitriy Sintsov 2011-05-18 09:35:24 UTC
My configs are quite simple. I do not use shorturl, rewrites and so on. What can be wrong with my configs, I cannot fix rendering in IE8/9 for two days (first in apache httpd mod_php, second in nginx php-fpm).
Comment 10 Bawolff (Brian Wolff) 2011-05-19 02:15:04 UTC
Sounds like bug 28840
Comment 11 Dmitriy Sintsov 2011-05-19 05:21:00 UTC
Thank you, Bawolff! I've applied your patch to my installation and the site works just fine!! You have saved my day and my project, which was running out of time. Big thanks.
Comment 12 Dmitriy Sintsov 2011-05-19 05:21:55 UTC
I hope the patch will be applied to http://svn.wikimedia.org/svnroot/mediawiki/branches/REL1_17/phase3

I've thought that it is not so unstable.
Comment 13 Bawolff (Brian Wolff) 2011-05-19 06:04:49 UTC

*** This bug has been marked as a duplicate of bug 28840 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links