Last modified: 2011-08-13 15:44:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28893 - Proofread Page extension needs an API module to retrieve page status
Proofread Page extension needs an API module to retrieve page status
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
ProofreadPage (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: John Du Hart
: patch, patch-need-review
Depends on:
Blocks: noncoreapi
  Show dependency treegraph
 
Reported: 2011-05-09 15:18 UTC by MZMcBride
Modified: 2011-08-13 15:44 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
ApiQuery prop module (3.18 KB, patch)
2011-08-08 17:51 UTC, John Du Hart
Details
Improved patch (4.24 KB, patch)
2011-08-09 22:04 UTC, John Du Hart
Details

Description MZMcBride 2011-05-09 15:18:31 UTC
The Proofread Page extension (<http://www.mediawiki.org/wiki/Extension:Proofread_Page>) needs an API module to allow users to retrieve the current status of a page (without text, problematic, etc.)
Comment 1 Mark A. Hershberger 2011-05-20 15:54:08 UTC
I would love something like this since (I think) I could use it to build my reCaptcha clone.
Comment 2 John Du Hart 2011-08-08 17:51:10 UTC
Created attachment 8897 [details]
ApiQuery prop module

Eh. I'm not sure if a FauxRequest and/or relying on the categories is the best route to go here (Pulling down an entire rev to run a regex seems wasteful when you have the categories). I need to ask Roan if running the API again internally is the right way.
Comment 3 John Du Hart 2011-08-09 22:04:54 UTC
Created attachment 8901 [details]
Improved patch

Roan and reedy confirmed this method was fine. Also added a namespace check and docs. I'll document this in my user space and put it on the extension page when it goes live.
Comment 4 Sam Reed (reedy) 2011-08-13 15:44:40 UTC
Thanks

r94418

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links