Last modified: 2012-02-22 12:36:21 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28877 - [rowiktionary] The value of the property 'hookEvent' is null or undefined, not a Function object
[rowiktionary] The value of the property 'hookEvent' is null or undefined, no...
Status: RESOLVED DUPLICATE of bug 28840
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
PC Windows Vista
: Unprioritized major (vote)
: ---
Assigned To: Krinkle
Depends on:
  Show dependency treegraph
Reported: 2011-05-07 20:25 UTC by Robert
Modified: 2012-02-22 12:36 UTC (History)
5 users (show)

See Also:
Web browser: Internet Explorer
Mobile Platform: ---
Assignee Huggle Beta Tester: ---

Wrong script (95.00 KB, application/octet-stream)
2011-05-07 20:25 UTC, Robert
When I try editing (363.00 KB, application/msword)
2011-05-08 20:14 UTC, Robert
Recent changes (409.00 KB, application/msword)
2011-05-08 20:15 UTC, Robert

Description Robert 2011-05-07 20:25:43 UTC
Created attachment 8518 [details]
Wrong script

For a couple of days now my account has been acting a bit "schizo". 

Even though I have Monobook, the appearance keeps changing. I'm unable to edit Wiktionary pages because the tool bar disappears every 10-15 minutes and I keep getting the following error message:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; Trident/5.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; InfoPath.2; .NET CLR 3.0.30729; OfficeLiveConnector.1.5; OfficeLivePatch.1.3; .NET4.0C; AskTbFWV5/
Timestamp: Sat, 7 May 2011 19:55:28 UTC

Message: The value of the property 'hookEvent' is null or undefined, not a Function object
Line: 1
Char: 730
Code: 0

It worked fine until about 2 days ago. I've tried fixing the script myself using advice from Microsoft, but it doesn't seem to work.
Comment 1 Bawolff (Brian Wolff) 2011-05-07 20:34:44 UTC
(technically this is probably not a mediawiki bug, but...)

On my testing, ie6, not only has a js error, no css is loaded...

cc'ing krinkle, because if i recall he was interested in these types of bugs (If I'm wrong on that, please ignore :)
Comment 2 Krinkle 2011-05-08 15:30:45 UTC
Thanks Bawolff, I am indeed interested in these kind of reports.

Although I'm not sure where they should go. Neither MediaWiki nor Wikimedia should/can fix this.
I'm trying to fix these things in the "2011 Resource Walker" edition [1] of Le Tour de Wikí [2].

Eventuelly we'll go through all wikis, but if any particular breakages occur (either because of the 1.17 upgrade or in general due to deprecated or invalid javascript/css, I would recommend putting an issue report on the talk page of the project [3].

Or, alternatively, on the talk page [5] of the Migration guide for users [4].

I'll move ro.wiktionary up on the list of to-be-checked wikis and tour it later tonight.
For now marking this as INVALID since it's not a bug in the MediaWiki software or the Wikimedia configuration.


Comment 3 Krinkle 2011-05-08 15:51:24 UTC
For the record, the tour through has just been completed.

The hookEvent issue was solved. If there are any problems, feel free to let us know on the project talk page:
Comment 4 Robert 2011-05-08 20:14:46 UTC
Created attachment 8522 [details]
When I try editing
Comment 5 Robert 2011-05-08 20:15:25 UTC
Created attachment 8523 [details]
Recent changes
Comment 6 Roan Kattouw 2011-05-09 11:49:51 UTC
(In reply to comment #5)
> Created attachment 8523 [details]
> Recent changes
Please don't attach .doc files. If you want to attach screenshots, attach them as PNGs or JPGs or something.

Also, are you saying the bug still isn't fixed? If so, please clearly state what's wrong.
Comment 7 Daniel Tar 2011-05-09 11:56:21 UTC
It the same as bug #28840, wikibits.js is not loaded along with all other legacy stuff in IE.

*** This bug has been marked as a duplicate of bug 28840 ***

Note You need to log in before you can comment on or make changes to this bug.