Last modified: 2014-11-18 18:07:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28874 - CSS/JS files fail to load in debug mode in IE9
CSS/JS files fail to load in debug mode in IE9
Status: RESOLVED DUPLICATE of bug 28840
Product: MediaWiki
Classification: Unclassified
ResourceLoader (Other open bugs)
unspecified
All All
: Unprioritized normal with 1 vote (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-07 18:26 UTC by Tisza Gergő
Modified: 2014-11-18 18:07 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
load.php returns wrong mime type in IE9 (21.90 KB, image/png)
2011-05-08 15:01 UTC, Pei-Tang Huang
Details

Description Tisza Gergő 2011-05-07 18:26:59 UTC
Debug mode breaks horribly in Internet Explorer 9: none of the CSS/JS files load, and the developer toolbar shows this message when one tries to view them: "This stylesheet cannot be viewed because its source is in a different domain than the page." IE9 in IE8 emulation mode works normally.
Comment 1 Tisza Gergő 2011-05-07 18:36:16 UTC
Might be due to lack of mime type headers:
http://blogs.msdn.com/b/ie/archive/2010/10/26/mime-handling-changes-in-internet-explorer.aspx
Comment 2 Pei-Tang Huang 2011-05-08 15:01:17 UTC
Created attachment 8521 [details]
load.php returns wrong mime type in IE9

Data reported by IE9 developer tools which approving Tisza's comment.
Comment 3 Derk-Jan Hartman 2011-05-08 15:18:32 UTC
It's not the content-type that is the problem. That is just a side effect of the 403 being returned from the request. This is the same problem as bug 28840

*** This bug has been marked as a duplicate of bug 28840 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links