Last modified: 2011-06-28 23:13:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28857 - Sometimes there's "undefined" in a Resource loader CSS request
Sometimes there's "undefined" in a Resource loader CSS request
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
ResourceLoader (Other open bugs)
1.18.x
All All
: High normal (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 29068
  Show dependency treegraph
 
Reported: 2011-05-06 18:23 UTC by Krinkle
Modified: 2011-06-28 23:13 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Krinkle 2011-05-06 18:23:54 UTC
Sometimes I get a pertially unstyled page,
such as today on http://www.mediawiki.org/wiki/Special:Code/MediaWiki/87555, the diff-styling was missing.

- no http errors
- no JS errors
- no HTML/DOM exceptions


http://bits.wikimedia.org/www.mediawiki.org/load.php?debug=false&lang=en&modules=site&only=styles&skin=vector
 line 0 undefined
 line 1 /* LOCAL MW.ORG STYLING HERE */@media print{  }@media handheld{  }
 line 2	
 line 3	/* cache key: mediawikiwiki:resourceloader:filter:minify-css:5:9d5d855a588ab73b56d717c4a7c9d656 */



I don't know for sure if the unstyled code review diffs is caused by this, but the "undefined" word is a bug for sure.
Comment 1 Krinkle 2011-05-06 18:26:24 UTC
As usual a refresh fixes these kind of errors, but it's a bug nontheless.


For what it's worth, I catched the following headers on that request:


Request method: GET
Status code: 304 Not Modified

Cache-Control: public, max-age=300, s-maxage=300
Connection: keep-alive
Date: Fri, 06 May 2011 18:14:55 GMT
Expires: Fri, 06 May 2011 18:15:14 GMT
Last-Modified: Wed, 04 May 2011 20:16:15 GMT
Vary: Accept-Encoding
Via: 1.1 varnish
X-Varnish: 2004502580
Comment 2 Mark A. Hershberger 2011-05-06 22:07:40 UTC
Could this be related to bug #28714?
Comment 3 Ningauble 2011-05-07 11:59:04 UTC
See also bug 28840 and bug 28851 !
See also problem reports at http://meta.wikimedia.org/wiki/Wikimedia_Forum#Troubles
Comment 4 Mark A. Hershberger 2011-05-09 15:11:41 UTC
(In reply to comment #3)
> See also bug 28840

Why do you think that one is related?  From what I can see, that one is an IE issue and what this bug describes it is not IE-specific.
Comment 5 Ningauble 2011-05-10 11:45:29 UTC
(In reply to comment #4)
> Why do you think that one is related?

Blind guess while driven to distraction. I know nothing about how the Resource loader works, but there were a lot of recent bug reports describing failure to render CSS. The symptoms were driving me crazy, crazy enough to hope there might be a single cause. The temporary patch at bug 28840 has relieved my pain, so I will stop groping in the dark.
Comment 6 Mark A. Hershberger 2011-05-10 14:04:38 UTC
(In reply to comment #5)
> The symptoms were driving me
> crazy, crazy enough to hope there might be a single cause. The temporary patch
> at bug 28840 has relieved my pain, so I will stop groping in the dark.

We're very interested in tracking this down but we're having trouble reproducing it.  Could you let us know what browser you're using?  Also, I assume you're seeing this on Wiki* site, not you're own installation of Mediawiki, is that correct?

If you were seeing this pretty consistently, your information would help us a lot.
Comment 7 Ningauble 2011-05-10 17:58:18 UTC
(In reply to comment #6)

The above linked (in comment 3) thread at Meta describes what I was seeing. I am using IE7 on Vista. Before the temporary patch at bug 28840, I was seeing the problem on "dif" pages 100% consistently at en.wikiquote. (It drove me crazy because I routinely spend 2-3 hours per day reviewing diffs at "Special:Recent changes".) This and other symptoms were only intermittent at Meta, and I am not sure whether I ever saw it at en.wikipedia.

Since the patch (Oooh, the cooolooouuurs!) I have only seen the failure to render CSS three times, and refreshing the page did the trick each time. Those three (at Meta, if I recall, but one may have been at either Meta or en.wikipedia) were a content page, a diff, and Special:Recent changes itself. Clearly there is more than one thing going on. The presumed cause mentioned at http://en.wikipedia.org/wiki/Wikipedia:Wikipedia_Signpost/2011-05-09/Technology_report#In_brief does not seem to correspond to what was done in the patch.
Comment 8 Krinkle 2011-06-28 23:12:34 UTC
All the bugs mentioned in the previous comments are fixed. I can no longer reproduce this, marking WORKSFORME for now.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links