Last modified: 2013-09-04 10:36:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28714 - Stalling only=styles requests (ResourceLoader) causing pages with no styling applied
Stalling only=styles requests (ResourceLoader) causing pages with no styling ...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
ResourceLoader (Other open bugs)
1.17.x
All All
: High major (vote)
: ---
Assigned To: Roan Kattouw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-27 01:54 UTC by Ryan Kaldari
Modified: 2013-09-04 10:36 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ryan Kaldari 2011-04-27 01:54:47 UTC
(This is probably actually a caching bug, but couldn't find where to file such bugs against. Feel free to reassign to a better component.)

I've seen this bug every once in a while ever since the 1.17 deploy, but was never able to reproduce it for debugging. I happened to catch it by accident with Firebug running today. It looks like what happened is:
1. The browser requested the page itself, which loaded in half a second
2. The browser next requested
http://bits.wikimedia.org/commons.wikimedia.org/load.php?debug=false&lang=en&modules=mediawiki.legacy.commonPrint%7Cmediawiki.legacy.shared%7Cskins.vector&only=styles&skin=vector
which waited for 6.2 seconds and then returned 0 bytes (but status 200 OK). The Cache headers on the response from bits were:

Last Modified	Tue Apr 26 2011 18:29:19 GMT-0700 (PDT)
Last Fetched	Tue Apr 26 2011 18:29:19 GMT-0700 (PDT)
Expires	Wed Dec 31 1969 16:00:00 GMT-0800 (PST)
Data Size	0
Fetch Count	28
Device	disk

Of course reloading the page fixed the problem, as it always does.
Comment 1 Roan Kattouw 2011-05-06 09:32:14 UTC
We've had an out-of-sync server in the pool for a while, that may have been what was causing this.
Comment 2 Mark A. Hershberger 2011-05-06 22:08:22 UTC
See also bug #28857 ?
Comment 3 Ningauble 2011-05-07 11:55:36 UTC
See also bug 28840 and bug 28851 !
See also problem reports at http://meta.wikimedia.org/wiki/Wikimedia_Forum#Troubles
Comment 4 Krinkle 2011-06-04 16:03:04 UTC
Appears to be fixed in general.

If still happening make sure it's not bug bug 28840 or bug 28857. Otherwise re-open this bug.
Comment 5 MZMcBride 2011-06-04 20:48:57 UTC
(In reply to comment #4)
> Appears to be fixed in general.
> 
> If still happening make sure it's not bug bug 28840 or bug 28857. Otherwise
> re-open this bug.

... or bug 29153.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links