Last modified: 2011-03-28 23:29:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27868 - Stylesheets fail to load occassionally
Stylesheets fail to load occassionally
Status: RESOLVED WORKSFORME
Product: Wikimedia
Classification: Unclassified
DNS (Other open bugs)
unspecified
All All
: Low normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 28016 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-05 09:23 UTC by Niklas Laxström
Modified: 2011-03-28 23:29 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Niklas Laxström 2011-03-05 09:23:16 UTC
[09:14:19]  OlEnglish> my vector.css isn't loading..
[09:14:31]  matthewrbowker> I hear it's been running since 5:00 UTC, if that helps anyone.
[11:03:24]  Nikerabbit> hmhm I've a page without styles twice today
[11:05:54]  Nikerabbit> http://bits.wikimedia.org/meta.wikimedia.org/load.php?debug=false&lang=fi&modules=user&only=styles&skin=vector&user=Nikerabbit&version=19700101T000001Z

The above url produces empty file which is cached. Is it possible to not cache empty files and investigate what causes them in the first place?
Comment 1 Roan Kattouw 2011-03-05 22:00:20 UTC
(In reply to comment #0)
> http://bits.wikimedia.org/meta.wikimedia.org/load.php?debug=false&lang=fi&modules=user&only=styles&skin=vector&user=Nikerabbit&version=19700101T000001Z
> 
> The above url produces empty file which is cached. Is it possible to not cache
> empty files and investigate what causes them in the first place?
That's not the cause. modules=user is *supposed* to return an empty response if you're not logged in or have no user CSS pages (the 1970 timestamp in the URL indicates that RL didn't find any). (On trunk, we take the modules=user request out entirely in that case (except if you have user JS but no CSS), but that change hasn't gone live yet.)

If the entire page appears unstyled, the request for skins.vector will be the one that's failing. The modules=user request is a red herring in this case.

If you have user CSS but it's not showing up (the bug report is a bit ambiguous as to whether it's about user CSS or all CSS not showing up), that's a whole 'nother story.
Comment 2 Niklas Laxström 2011-03-05 22:38:24 UTC
Okay, I misdiagnosed it. Some vector styles were indeed missing.
Comment 3 Mulat 2011-03-11 08:58:51 UTC
On plwiki we have numerous reports from both registered and IP users that random pages load recently without formatting. I have just experienced this exactly this minute I am writing this comment (page [http://pl.wikipedia.org/wiki/Wikipedia:Kawiarenka/Kwestie_techniczne#Propozycja_przywr.C3.B3cenia_poprzedniej_wersji_MediaWiki])  see screenshot: [http://commons.wikimedia.org/wiki/File:Plwiki_no_CSS_bug.JPG]
Comment 4 Krinkle 2011-03-14 20:34:58 UTC
Possible caused by outdated squid caches from before 1.17 deployment which contains references to old 1.16 resources that no longer exist on the server.

Related to bug 27935.

Cache will invalidate automatically within 30 days.
Comment 5 Krinkle 2011-03-14 20:38:03 UTC
Please report here if this is not fixed by March 20 (which roughly 30 days after the final deployment on Feb 16/17)
Comment 6 Krinkle 2011-03-16 23:56:54 UTC
*** Bug 28016 has been marked as a duplicate of this bug. ***
Comment 7 random person 2011-03-20 21:04:03 UTC
It's march 20 now and it still happens :(

For me it doesn't fail to load "just occasionally" but constantly on my home connection. My ISP's DNS servers just won't translate bits.wikimedia.org to 91.198.174.233 and i have to edit hosts file by force.

I've switched to Google DNS where this happens only occasionally, but still does some times.

Also, check out the comments on this page: http://techblog.wikimedia.org/2010/03/global-outage-cooling-failure-and-dns/ 
seems this problem has been around for a long time now.
Comment 8 Roan Kattouw 2011-03-21 10:24:45 UTC
(In reply to comment #7)
> It's march 20 now and it still happens :(
> 
> For me it doesn't fail to load "just occasionally" but constantly on my home
> connection. My ISP's DNS servers just won't translate bits.wikimedia.org to
> 91.198.174.233 and i have to edit hosts file by force.
> 
Can you figure out what bits.wm.o does resolve to then?
Comment 9 Mark A. Hershberger 2011-03-28 23:28:17 UTC
localized problem, worksforme, and seems otherwise solved.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links