Last modified: 2014-08-17 11:45:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27819 - Internal error on uploading file/multiple files
Internal error on uploading file/multiple files
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Uploading (Other open bugs)
1.17.x
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
aklapper-moreinfo
: testme
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-02 07:03 UTC by Eduard
Modified: 2014-08-17 11:45 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Eduard 2011-03-02 07:03:47 UTC
MediaWiki 	1.17wmf1
PHP 	        5.2.12 (apache)
MySQL 	        5.0.90-log


I changed the location of my wiki site from /domainname.com/www/wiki to /domainname.com/www to have my site accessible just  from the domainname.com address. After that I run webinstall again and /maintenance/rebuildall.php. I changed links in LocalSettings.php
Everything seems to work fine except two things:
1. When Upload a file or try to upload multiple files I have got the following internal error:

key 'nr18v590ge8l35sttb090ccpr65s77q.' is not in a proper format

Backtrace:

#0 /home/u19329/hdlwiki.com/www/includes/upload/UploadBase.php(634): UploadStash->stashFile('/home/u19329/hd...', Array, NULL)
#1 /home/u19329/hdlwiki.com/www/includes/upload/UploadBase.php(646): UploadBase->stashSessionFile(NULL)
#2 /home/u19329/hdlwiki.com/www/includes/specials/SpecialUpload.php(367): UploadBase->stashSession()
#3 /home/u19329/hdlwiki.com/www/includes/specials/SpecialUpload.php(461): SpecialUpload->showUploadWarning(Array)
#4 /home/u19329/hdlwiki.com/www/includes/specials/SpecialUpload.php(192): SpecialUpload->processUpload()
#5 /home/u19329/hdlwiki.com/www/includes/SpecialPage.php(579): SpecialUpload->execute(NULL)
#6 /home/u19329/hdlwiki.com/www/includes/Wiki.php(250): SpecialPage::executePath(Object(Title))
#7 /home/u19329/hdlwiki.com/www/includes/Wiki.php(63): MediaWiki->handleSpecialCases(Object(Title), Object(OutputPage), Object(WebRequest))
#8 /home/u19329/hdlwiki.com/www/index.php(114): MediaWiki->performRequestForTitle(Object(Title), NULL, Object(OutputPage), Object(User), Object(WebRequest))
#9 {main} 

2. I checked the site log file provided by my host company and found the following error:
[Wed Mar 2 09:27:49 2011] [error] PHP Warning: filemtime() [<a href='function.filemtime'>function.filemtime</a>]: stat failed for /home/u19329/hdlwiki.com/www/wiki/extensions/WikiEditor/modules/./images/toc/grip.png in /home/u19329/hdlwiki.com/www/includes/resourceloader/ResourceLoaderFileModule.php on line 363

There were more lines regarding different files.
In fact the WikiEditor extension works fine and I don't understand where and why does this error come from. It seems that there is a problem with a path since it changed from /wiki to /*.

I would appreciate any help to solve these problems?
Thanks in advance
Comment 1 Mark A. Hershberger 2011-03-04 17:56:14 UTC
The key you're getting seems very odd.  Does this problem still happen after you clear your cookies?
Comment 2 Bryan Tong Minh 2011-03-04 18:11:20 UTC
This happens when stashing an upload for which no matching extension for the mimetype can be found.
Comment 3 Mark A. Hershberger 2011-03-05 00:25:28 UTC
Eduard, What is the name of the file you're uploading?
Comment 4 Eduard 2011-03-05 11:27:37 UTC
(In reply to comment #3)
> Eduard, What is the name of the file you're uploading?

In fact, I tried different files png, jpg, svg. What is more interesting is that this error appears occasionally. First I had installed Multiupload extension. Tried to upload from 5 to 10 files and failed. Then I stopped this extension and tried embedded upload file feature. And uploading were several times successful as well as failed. I guess that it can cause the memory limit. I have only 32Mb available. Another reason could be the temporary folder problem I have.
See another post http://www.mediawiki.org/w/index.php?title=Project:Support_desk&offset=20110302175814&limit=20#upload_tmp_dir__-_MediaWiki_ignores_php_specified_path_2699
All of these happened when I upgraded MW to 1.17wmf1 from 1.16.2 and changed the location from domainname.com/wiki/ to domainname.com/
Extensions I also upgraded.
Sorry, I cannot provide more technical details, since I am not familiar with programming. It is my first experience.
Best regards,
Eduard
Comment 5 Mark A. Hershberger 2011-03-26 06:17:34 UTC
There was another bug recently where an upload problem was caused by the hoster when they changed out of the /wiki/ directory.  Does the problem happen when the site is hosted in /wiki/ instead of the root?
Comment 6 Mark A. Hershberger 2011-03-26 06:37:03 UTC
Also, removing the 1.17 blocker from this since, upon closer inspection, it looks like it is local to the installation.
Comment 7 Thehelpfulone 2012-06-22 19:40:27 UTC
Reassigning to wikibugs-l per bug 37789
Comment 8 Andre Klapper 2013-09-04 10:40:45 UTC
Eduard: If this is still an issue, could you answer comment 5, please?
Comment 9 Bawolff (Brian Wolff) 2014-05-22 16:36:10 UTC
1.17 was a long time ago. Is this still an issue to you?
Comment 10 Andre Klapper 2014-08-17 11:45:03 UTC
Unfortunately closing this report as no further information has been provided.

Eduard: Please feel free to reopen this report if you can provide the information asked for in comment 8 and comment 9 and if this still happens. Thanks!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links