Last modified: 2011-03-27 20:46:53 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27579 - [Installer] Chrome saves config as LocalSettings.php.php
[Installer] Chrome saves config as LocalSettings.php.php
Status: RESOLVED WORKSFORME
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.18.x
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 26676
  Show dependency treegraph
 
Reported: 2011-02-20 08:03 UTC by Max Semenik
Modified: 2011-03-27 20:46 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot (41.78 KB, image/png)
2011-02-20 08:03 UTC, Max Semenik
Details

Description Max Semenik 2011-02-20 08:03:09 UTC
Created attachment 8177 [details]
Screenshot

Chrome 6.0.466.0 dev/Win always saves with double extension although in UI it looks like everything's going to be OK (see attachment). "Hide extensions for known file types" system option doesn't seem to affect this.
Comment 1 Happy-melon 2011-03-20 19:03:23 UTC
Confirmed variously on Chrome 10.0.648 (current stable) and 11.0.696 (current dev).
Comment 2 Happy-melon 2011-03-22 17:34:39 UTC
But *not* confirmed with Chrome 10.0.648 with Windows Vista.  OS issue?
Comment 3 Brion Vibber 2011-03-27 20:43:42 UTC
I cannot reproduce this with Chrome 10.0.648 on Windows XP. The file auto-saves as "LocalSettings.php" in my downloads dir... if I right-click on the link and select 'save file as', I see "LocalSettings" as the suggested filename, with .php in the extension box. Files get saved as expected as "LocalSettings.php", no double extension.

Changing Chrome settings to require prompting me instead of auto-saving to %HOME%\My Documents\Downloads doesn't seem to affect this, I still get the expected behavior.

Might depend on OS settings.
Comment 4 Brion Vibber 2011-03-27 20:46:53 UTC
I'm going to provisionally close this out; quick googly search seems to indicate that this is still sometimes a Chrome issue, but depends on vague mysterious things that no one can pinpoint -- possibly on what other applications have claimed ownership of file types or some such horror that's unpredictable.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links