Last modified: 2011-03-22 23:07:44 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27470 - Upload blacklist for target names not being applied
Upload blacklist for target names not being applied
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
TitleBlacklist (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Sam Reed (reedy)
:
Depends on: 28166
Blocks: 27339
  Show dependency treegraph
 
Reported: 2011-02-16 20:16 UTC by Derk-Jan Hartman
Modified: 2011-03-22 23:07 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2011-02-16 20:16:23 UTC
Commons reports that the list that blocks DSC902458 etc uploads is not functioning.
Comment 1 Bryan Tong Minh 2011-02-16 20:49:08 UTC
I am not aware of a list that blocks such uploads, only a list that warns when such files are uploaded. That list is working, I entered as filename "DSC000001.jpg" and I get a warning: 

The name of the file you are uploading begins with "IMG", which is a non-descriptive name typically assigned automatically by digital cameras. Please choose a more descriptive name for your file.
Comment 2 DieBuche 2011-02-16 21:11:37 UTC
It's done via MediaWiki:Titleblacklist and MediaWiki:Titleblacklist-custom-filename
Comment 3 Bryan Tong Minh 2011-02-16 21:27:20 UTC
That's an extension, changing category.
Comment 4 Derk-Jan Hartman 2011-02-25 09:09:11 UTC
*** Bug 27339 has been marked as a duplicate of this bug. ***
Comment 5 Derk-Jan Hartman 2011-02-25 09:14:54 UTC
*** Bug 27700 has been marked as a duplicate of this bug. ***
Comment 6 Krinkle 2011-03-14 20:48:36 UTC
I just reproduced it here from both a sysop and non-sysop account:
http://commons.wikimedia.org/wiki/File:DSC902458.jpg

Did not get blocked by title blacklist.
Comment 7 Sam Reed (reedy) 2011-03-14 22:20:10 UTC
Can seemingly reproduce locally. But not too familiar with code. Will poke it when I've got a bit more time
Comment 8 Sam Reed (reedy) 2011-03-17 22:16:43 UTC
No idea about how it's supposed to work

$wgHooks['EditFilter'][] = 'TitleBlacklistHooks::validateBlacklist';

It would seem, that creating a file page doesn't hit this hook call, at all.

Blocking redirects to non existent blacklisted titles seems to work fine, as does "The title "Meh on wheels" has been banned from creation. It matches the following blacklist entry: .*? on wheels"

Just no hits for image uploads for whatever reason..
Comment 9 Sam Reed (reedy) 2011-03-17 22:23:29 UTC
That and there seems to be no code actually preventing any sort of new titles from being created.

Almost seems like we're barking up the wrong tree...
Comment 10 Sam Reed (reedy) 2011-03-21 20:56:38 UTC
<vvv> Reedy: probably someone removed check for page creation permission from upload module
<vvv> Was it rewritten in 1.17?
<Reedy> I think so
<snip>
<vvv> Reedy: it looks like UploadBase assumes that 'edit', 'upload', etc are not per-page restrictions
<vvv> Reedy: oh, and it also allows to upload images even when they are create-protected
Comment 11 Bryan Tong Minh 2011-03-22 08:39:02 UTC
UploadBase::verifyPermissions() ?
Comment 12 Sam Reed (reedy) 2011-03-22 22:37:09 UTC
Fixed with r84573 and r84575

However, seems I broke some error handling in r83979, will investigate
Comment 13 Sam Reed (reedy) 2011-03-22 23:07:44 UTC
Actually properly fixed in r84581

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links