Last modified: 2012-02-24 02:52:06 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27363 - Mobile RTL Wikipedias' main pages are displayed as LTR
Mobile RTL Wikipedias' main pages are displayed as LTR
Status: RESOLVED FIXED
Product: Wikipedia App
Classification: Unclassified
Generic (Other open bugs)
1.0.0 (Android)
All All
: Normal normal
: ---
Assigned To: Nobody - You can work on this!
http://he.m.wikipedia.org/
: i18n
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2011-02-12 14:55 UTC by Amir E. Aharoni
Modified: 2012-02-24 02:52 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: Android
Assignee Huggle Beta Tester: ---


Attachments

Description Amir E. Aharoni 2011-02-12 14:55:56 UTC
Both http://he.m.wikipedia.org/ and http://ar.m.wikipedia.org/ are displayed left-to-right in the mobile version. I tried on Windows XP and on my mobile phone (Samsung Monte). People are actually complaining about it.
Comment 1 Aude 2011-02-17 11:18:45 UTC
Confirm problem on iPhone and Ubuntu+Firefox. This is very important to get fixed soon.
Comment 2 Brion Vibber 2011-04-29 17:59:40 UTC
I'm seeing this on the *home page* for http://ar.m.wikipedia.org/ http://ckb.m.wikipedia.org/ http://fa.m.wikipedia.org/ etc ...

... but actual *article pages* are coming up RTL:

http://ckb.m.wikipedia.org/wiki/%DA%98%D8%A7%D9%BE%DB%86%D9%86
http://ar.m.wikipedia.org/wiki/%D8%AE%D9%84%D9%8A%D9%81%D8%A9
http://he.m.wikipedia.org/wiki/%D7%94%D7%97%D7%9C%D7%95%D7%A5

... except sometimes they *do* come up LTR on the first view, then RTL on the second.

Might be related to caching or such; the home pages might always come up wrong because they're not showing a regular page as such?
Comment 3 Hampton Catlin 2011-05-23 13:11:28 UTC
Fixed in the most recent release (deploying soon)
Comment 4 Amir E. Aharoni 2012-01-10 21:42:54 UTC
I'm seeing the same problem on the Android app now. Regression?
Comment 5 Amir E. Aharoni 2012-01-13 10:49:21 UTC
I reopened it in RC5, but it doesn't seem to happen in RC5. Fixed?

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links