Last modified: 2011-02-20 19:27:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27355 - Classic edit toolbar buttons fail in IE6 when WikiEditor automatically falls back
Classic edit toolbar buttons fail in IE6 when WikiEditor automatically falls ...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
WikiEditor (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/rc-en/...
:
Depends on:
Blocks: 640 26676
  Show dependency treegraph
 
Reported: 2011-02-12 06:06 UTC by Brion Vibber
Modified: 2011-02-20 19:27 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot IE6 with error dialog open (32.25 KB, image/png)
2011-02-12 06:06 UTC, Brion Vibber
Details

Description Brion Vibber 2011-02-12 06:06:28 UTC
Created attachment 8131 [details]
Screenshot IE6 with error dialog open

WikiEditor does a little browser detection to automatically fall back to the classic toolbar when on some known-broken browsers like IE 6.

Unfortunately it looks like something in the behavior for the toolbar buttons doesn't get fully left alone; when clicking any of the buttons (bold, nowiki, etc) in this mode I get a JS error:

  '$iframe' is null or not an object

Disabling the WikiEditor extension, this doesn't happen.

Tested on prototype r82004 and trunk r82002
Comment 1 Roan Kattouw 2011-02-20 19:27:20 UTC
Fixed in r82530.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links