Last modified: 2012-02-28 20:54:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27150 - Database query error (1267) while login/signup attempt
Database query error (1267) while login/signup attempt
Status: RESOLVED WONTFIX
Product: Wikimedia
Classification: Unclassified
Prototype server (Other open bugs)
unspecified
All All
: Normal critical (vote)
: ---
Assigned To: Roan Kattouw
http://prototype.wikimedia.org/rc-pl/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-04 03:27 UTC by Mikołka
Modified: 2012-02-28 20:54 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Mikołka 2011-02-04 03:27:11 UTC
I keep getting an error on http://prototype.wikimedia.org/rc-pl/index.php?title=Specjalna:Zaloguj when attemting to login/create an account with my username containing polish diacritical marks (Mikołka). The error notice says:

Błąd bazy danych

Wystąpił błąd składni w zapytaniu do bazy danych. Może to oznaczać błąd w oprogramowaniu. Ostatnie, nieudane zapytanie to:

    SELECT gu_id, lu_wiki, gu_salt, gu_password,gu_auth_token, gu_locked,gu_hidden, gu_registration, gu_email, gu_email_authenticated, gu_home_db FROM `globaluser` LEFT OUTER JOIN `localuser` ON gu_name=lu_name AND lu_wiki='rc_plwiki' WHERE gu_name='Mikołka'

wysłane przez funkcję „DatabaseBase::safeQuery”. Baza danych zgłosiła błąd „1267: Illegal mix of collations (latin1_bin,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '=' (localhost)”.
Comment 1 Mikołka 2011-02-04 03:42:44 UTC
MediaWiki version: 1.17alpha (r81444)
Comment 2 Mark A. Hershberger 2011-02-04 15:28:22 UTC
Hrm.  Thanks, this looks like it might affect deployment.
Comment 3 Bryan Tong Minh 2011-02-04 15:33:26 UTC
I think this is caused by [[Manual:$wgDBmysql5]] = true; which is not set on Wikimedia.
Comment 4 Brion Vibber 2011-02-04 17:58:35 UTC
This generally indicates that the databases haven't been properly maintained and there's a mismatch in data types between various tables.

Most likely an ops issue for prototype server?
Comment 5 Antoine "hashar" Musso (WMF) 2012-02-28 20:54:48 UTC
The prototype server is being decommissioned hence any issue with it will disappear whenever the shutdown button is pressed.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links