Last modified: 2011-03-14 15:02:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27052 - CSS minification regression in ResourceLoader: relative links to images not resolved correctly
CSS minification regression in ResourceLoader: relative links to images not r...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
ResourceLoader (Other open bugs)
1.18.x
All All
: Normal blocker (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-30 22:31 UTC by Brion Vibber
Modified: 2011-03-14 15:02 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Brion Vibber 2011-01-30 22:31:13 UTC
I noticed a regression in the CSS minification that has broken the load/save spinner from showing in SVGEdit extension...

From styles in ext.svgedit.edit.editButton.css; original source:

#mw-svgedit-spinner {
	position: absolute;
    top: 2em;
    left: 0;
    right: 0;
    bottom: 0;
    background: rgba(0,0,0,0.5)
		 url("../images/ajax-loader.gif")
		 50%
		 no-repeat;
    z-index: 999999
}

as minified with current trunk code:

#mw-svgedit-spinner {
    background: url("/trunk/extensions/SVGEdit/modules//../images/ajax-loader.gif?2011-01-22T00:58:20Z") no-repeat scroll 50% 50% rgba(0, 0, 0, 0.5);


This ends up resolving to (on my localhost):
http://stormcloud.local/trunk/extensions/SVGEdit/modules/images/ajax-loader.gif?2011-01-22T00:58:20Z

where it should instead load:
http://stormcloud.local/trunk/extensions/SVGEdit/images/ajax-loader.gif?2011-01-22T00:58:20Z

Looks like the problem is that double slash: "modules//../images" -- if it instead said "modules/../images" it should at least resolve correctly client-side.

Relative module paths used for SVGEdit's module:

$myResourceTemplate = array(
	'localBasePath' => dirname( __FILE__ ) . '/modules',
	'remoteExtPath' => 'SVGEdit/modules',
	'group' => 'ext.svgedit',
);

Possible workaround: relative paths that don't need to bump into "../" territory appear to work with the double slashes, so if image and font resources are always at the same directory level or in a subdirectory of where the CSS lives, it should still work.
Comment 1 Roan Kattouw 2011-03-14 15:02:31 UTC
Fixed in r83902 by eliminating double slashes.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links