Last modified: 2011-01-19 19:00:50 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26781 - Leading asterisk, hash, colon or semicolon in parser function output incorrectly parsed as if beginning a line
Leading asterisk, hash, colon or semicolon in parser function output incorrec...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.18.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.mediawiki.org/wiki/*foo
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-17 20:06 UTC by Ilmari Karonen
Modified: 2011-01-19 19:00 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ilmari Karonen 2011-01-17 20:06:28 UTC
If the output of a parser function or magic word begins with "*", "#", ":" or ";", it will be parsed as a list item even if it's not actually at the beginning of a line.

This bug has been observed on both 1.16.1, current wikimedia-deployment and 1.18-svn.  It can be easily reproduced by parsing e.g. "foo{{plural:1|*bar}}", which should yield "foo*bar".  Instead, the string gets incorrectly parsed as "foo<ul><li>bar</li></ul>".

Another way to observe this bug (and the context in which it was first noticed) is to visit a nonexistent page with a leading asterisk in its title: the {{PAGENAME}} magic word in the noarticletext message also triggers this bug if its output begins with an asterisk.
Comment 1 Bawolff (Brian Wolff) 2011-01-18 00:59:18 UTC
sounds like Bug 12974
Comment 2 Ilmari Karonen 2011-01-18 20:21:40 UTC
There seem to actually be two bugs here.  r80511 and r80512 should fix the issue of insufficient escaping of the output of {{PAGENAME}} and friends.  Meanwhile, r80430 addresses the more general issue of handling template / parser function output beginning with "*#;:" characters (which seems to be a regression from bug 529).  Assuming that neither fix is reverted, I think this bug can probably be closed.
Comment 3 Mark A. Hershberger 2011-01-19 19:00:50 UTC
feel free to re-open if they are reverted.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links