Last modified: 2012-04-16 09:15:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26512 - Suggest: MouseOver link definitions, right-click functionality
Suggest: MouseOver link definitions, right-click functionality
Status: RESOLVED DUPLICATE of bug 503
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-30 19:04 UTC by JB
Modified: 2012-04-16 09:15 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description JB 2010-12-30 19:04:00 UTC
Background:
Wikimedia page prose contains many hyperlinks.  Google.com recently added page previews when MouseOver-ing search results.  Other websites provide popups on selected words, generally with a commercial theme.  Wikimedia pages can contain several terms in the same sentence that may all require lookup.

e.g. from http://en.wikipedia.org/wiki/Eye_disease
H00-H06 Disorders of eyelid, lacrimal system and orbit
    * (H00.0) Hordeolum ("stye" or "sty") — a bacterial infection of sebaceous glands of eyelashes.
    * (H00.1) Chalazion — a cyst in the eyelid (usually upper eyelid)
    * (H01.0) Blepharitis — inflammation of eyelids and eyelashes; characterized by white flaky skin near the eyelashes
    * (H02.0) Entropion and trichiasis
    * (H02.1) Ectropion
    * (H02.2) Lagophthalmos
    * (H02.3) Blepharochalasis
    * (H02.4) Ptosis
    * (H02.6) Xanthelasma of eyelid

H00.0 to H02.6 are all links.  The first three are explicitly defined, perhaps giving the user enough info to not have to navigate away from the current page.  To understand the last 6 items requires clicking the links.

Suggestion: Page links to show popup meanings or definitions of the source word(s) when user's mouse hovers over them.  The information displayed would be a definition field that the author populates when s/he edits the page.  This allows for more fluid intake of information, since page flipping to understand each phrase would be reduced.

Suggestion: Create a Wikipedia addon giving user context-sensitive right-click capabilities, such as the one described above. Another example: "Copy" or "Save high resolution image" might be offered when over a right hand side thumbnail.  The higher resolution image that resides on a separate page would then be copied onto the clipboard or saved.  Another time saver: select text, right-click and have option to "Search Wikipedia for <textselected>."

Thanks for taking the time to review this message.
Comment 1 Chad H. 2010-12-30 19:09:44 UTC

*** This bug has been marked as a duplicate of bug 503 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links