Last modified: 2011-04-20 07:24:36 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 25888 - no tidy for the html-preview
no tidy for the html-preview
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
ExpandTemplates (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://de.wikipedia.org/wiki/Spezial:...
: patch, patch-need-review
: 21621 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-11 20:20 UTC by Bergi
Modified: 2011-04-20 07:24 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Add Tidy option to ExpandTemplates (2.77 KB, patch)
2010-11-12 23:18 UTC, Derk-Jan Hartman
Details

Description Bergi 2010-11-11 20:20:39 UTC
When you preview unclosed tags, they are not fixed by the Sanitizer. So their styles affect all the following elements, first of all the sidebar. Also try this link: http://de.wikipedia.org/wiki/Spezial:Vorlagen_expandieren?input=%3Cdiv%3E

The Layout is smashed into pieces which shouldnt happen.
Comment 1 Derk-Jan Hartman 2010-11-12 23:18:58 UTC
Created attachment 7814 [details]
Add Tidy option to ExpandTemplates

This actually adds a tidy option to the ExpandTemplates option. Default is to tidy.

Untested, since I don't use tidy here.
Comment 2 Bergi 2010-11-13 20:49:59 UTC
I don't think its necessary to have a option. Whoever would like to see untidied HTML can use the API (action=parse).
Comment 3 Derk-Jan Hartman 2010-11-19 02:02:19 UTC
done in r77003
Comment 4 Bergi 2011-04-20 07:24:36 UTC
*** Bug 21621 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links