Last modified: 2011-03-13 18:05:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 25061 - Table of contents problem on right to left languages
Table of contents problem on right to left languages
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
unspecified
All All
: Lowest enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://ar.wikipedia.org/wiki/%D9%85%D...
:
: 25060 (view as bug list)
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2010-09-05 00:54 UTC by [no longer active user]
Modified: 2011-03-13 18:05 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
arabic wiki TOC problem (33.39 KB, image/png)
2010-09-05 01:01 UTC, [no longer active user]
Details

Description [no longer active user] 2010-09-05 00:54:33 UTC
Term of content number have problem on Right To Left language.

something same this:
== a ==
== b ==
=== c ===
== a ==
== b ==
=== c ===
must become this on toc:

Contents [hide]
1 a
2 b
2.1 c
3 a
4 b
4.1 c

but on RTL wiki, we are seeing other thing! something same:
1 a
2 b
1.2 c
3 a
4 b
1.4 c

(numbers are inverted)

for fix this problem, we can easily put
 
.tocnumber {
	unicode-bidi:bidi-override;
	direction:rtl;
}

on main-rtl.css that can fix this problem on rtl languages.

thanks.

thanks.
Comment 1 [no longer active user] 2010-09-05 01:01:44 UTC
Created attachment 7672 [details]
arabic wiki TOC problem
Comment 2 Casey Brown 2010-09-05 01:25:35 UTC
(In reply to comment #0)
> but on RTL wiki, we are seeing other thing! something same:
> 1 a
> 2 b
> 1.2 c
> 3 a
> 4 b
> 1.4 c
> 

Hmm?  In the screenshot you gave, I see

   a 1
   b 2
c 2.1
   a 3
   b 4
c 4.1

which is, afaik, the intended look.
Comment 3 [no longer active user] 2010-09-05 01:27:21 UTC
   a 1
   b 2
c 1.2
   a 3
   b 4
c 1.4

is true.
Comment 4 Casey Brown 2010-09-05 01:33:53 UTC
Hrm, that's not what I would think it would from my knowledge of the way numbers are handled in right-to-left languages, but I don't know *that* much about RTL languages.  I'm CC'ing a few other RTL users to see if they can confirm that this is wrong.  (Mardetanha/Huji from fawiki and Mido/Meno25 from arwiki)
Comment 5 [no longer active user] 2010-09-05 01:40:27 UTC
okay, i will tell mardetanha and huji,
also i must say that my css is not good solution for this problem (because it will convert 23.1 to 1.32 that is not true(we want 1.23!).)
Comment 6 Muhammad Yahia 2010-09-05 05:12:03 UTC
Ebraminio,

The numbers display correctly in both the screenshot you provided and on my machine. I don't see the problem?
Comment 7 [no longer active user] 2010-09-05 09:03:23 UTC
                                                                        a 1
                                                                        b 2
                                                                     c 2.1
                                                                     d 2.2
                                                                     e 2.3
                                                                     f 2.4
                                                                        a 3
                                                                        b 4
                                                                     c 4.1
                                                                     d 4.2
                                                                     e 4.3
                                                                     f 4.4

is correct?

correct one:

                                                                        a 1
                                                                        b 2
                                                                     c 1.2
                                                                     d 2.2
                                                                     e 3.2
                                                                     f 4.2
                                                                        a 3
                                                                        b 4
                                                                     c 1.4
                                                                     d 2.4
                                                                     e 3.4
                                                                     f 4.4
Comment 8 Alexandre Emsenhuber [IAlex] 2010-09-05 10:55:33 UTC
*** Bug 25060 has been marked as a duplicate of this bug. ***
Comment 9 Chad H. 2010-09-08 15:33:46 UTC
Summary tweak.
Comment 10 Chad H. 2010-09-08 15:33:46 UTC
Summary tweak.
Comment 11 Huji 2010-10-26 19:26:56 UTC
Do we still have this problem?
Comment 12 Muhammad Yahia 2010-10-26 20:04:53 UTC
Several ar.wp (me included) users have failed to see what exactly the problem is. The behavior the user is asking for is inconsistent (he wants Arabic numerals to be formed in RTL including the decimal designator, which is not correct, Hindu numerals can be used as so but not Arabic ones, they are universally treated as LTR even in Arabic).I think this is a non-issue.

See: http://en.wikipedia.org/wiki/Hindu-Arabic_numeral_system
Comment 13 Huji 2010-10-27 14:22:06 UTC
I thought the case was just the opposite! Somebody was complaining that Arabic numerals are incorrectly treated as RTL in RTL wikis, while they should always be treated as LTR.

Anyways, do we have a test case of this bug right now?
Comment 14 [no longer active user] 2010-10-27 16:06:48 UTC
well, i have not insistence about this, that was a problem that someone said in our villagepomp and i just reported that here (with the solution that i thought good). we can see section numbering that used in RTL languages books and articles. in persian, some books have used the way that i said and some not! i dont know about arabic or hebrew books and article. you can see them.
Comment 15 Muhammad Yahia 2010-10-27 17:09:18 UTC
I think this is something that can be put in the user preference, or handled on a per wiki basis. If fa.wp has a consensus that this is right for them the bug should be submitted just for fa.wp.
Comment 16 Huji 2010-10-27 23:36:53 UTC
I guess this already being handled on Fa WP using CSS. I guess (not sure) the intent of this bug was to include that piece of CSS in the master RTL.css files, but I might have misunderstood the whole bug.
Comment 17 Muhammad Yahia 2010-10-28 00:24:24 UTC
I think it should be per wiki, definitely not in the master css. There is no consensus on how to display that in different RTL wikis. Should we be closing this one?
Comment 18 Huji 2010-10-28 04:57:28 UTC
I don't see a reason not to. I'm marking it as won't fix.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links