Last modified: 2012-08-14 01:22:27 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24984 - Thumbnailing errors for tiffs
Thumbnailing errors for tiffs
Status: RESOLVED DUPLICATE of bug 25647
Product: MediaWiki extensions
Classification: Unclassified
PagedTiffHandler (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 23258
  Show dependency treegraph
 
Reported: 2010-08-30 15:39 UTC by Derk-Jan Hartman
Modified: 2012-08-14 01:22 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2010-08-30 15:39:14 UTC
I see three common problems in http://commons.wikimedia.org/wiki/Category:Tiff_files

1: Thumb of: "Error creating thumbnail: The uploaded file contains errors."
2: Empty thumb with: "Error generating thumbnail

Error creating thumbnail: The resolution of the source file is too large.
No thumbnail will be generated."

3: Thumb of: "Error creating thumbnail: Cannot get metadata from TIFF"

The latter can be solved by Purging the image by hand (dirty/non-existant serialized metadata ?). This last one can probably be fixed easily.
Comment 1 Derk-Jan Hartman 2010-08-30 15:48:16 UTC
Another set of tiffs with trouble is http://commons.wikimedia.org/wiki/Category:Scanned_French_books_in_TIFF

For these it seems as if the dimensions cannot be detected or something.
Comment 2 Derk-Jan Hartman 2010-08-30 16:30:00 UTC
problem 1: tiff_bad_file

Problem of 3, tiff_no_metadata, most likely originates in doTransform()'s $pagesize = PagedTiffImage::getPageSize($meta, $page);
A purge fixes this, because getMetaArray(), uses isMetadataValid(), but doesn't actually blank the previous metadata, instead just ignoring the situation, thus no automatic call of upgradeRow ??
Comment 3 Markus Glaser 2010-08-30 17:40:37 UTC
I will look at this asap. Some tiff images cannot be rendered by the rendering engine. That's where the error messages come from. Metadata should be invalidated if there are errors and it is supposed to be recreated after some time. however, there have been some changes to that mechanism recently, so I need to do some investigations.
Comment 4 Tim Starling 2010-08-31 13:11:56 UTC
I downloaded a few images with metadata extraction issues. They were all created by Photoshop. The tiffinfo output in that case is pretty ugly, with tags with line breaks in them. Example: 

http://commons.wikimedia.org/wiki/File:Circle-red2.tif
Comment 5 Daniel Kinzler 2010-08-31 14:28:44 UTC
I see hardly any thumbnails rendering in http://commons.wikimedia.org/wiki/Category:Tiff_files - for most files, i still see the blank placeholder image. Looks like rendering isn't triggered. What gives?
Comment 6 Daniel Kinzler 2010-09-03 12:01:50 UTC
partial fix in r72278: metadata processing is no longer aborted when a warning is encountered. This should fix problem no 1 from the original report: "uploaded file contains errors". I have not investigated the need to purge pages with "Cannot get metadata from TIFF".
Comment 7 Jeff G. 2011-02-11 18:57:39 UTC
Currently, 13 of 104 images (12.5%) in http://commons.wikimedia.org/wiki/Category:TIFF_images (the new name for http://commons.wikimedia.org/wiki/Category:Tiff_files ) are not thumbnailing. :(
Comment 8 Mark A. Hershberger 2011-02-11 19:17:22 UTC
At least one of those is a PNG image, though: http://commons.wikimedia.org/wiki/File:A_Leslie_Scott.tif
Comment 9 Jeff G. 2011-02-12 15:06:50 UTC
(In reply to comment #8)
> At least one of those is a PNG image, though:
> http://commons.wikimedia.org/wiki/File:A_Leslie_Scott.tif

Thanks, I marked it with "{{duplicate|A Leslie Scott.png}}".
Comment 10 Derk-Jan Hartman 2011-02-12 15:23:04 UTC
And for most of the others, the source resolution is simply too high.  It's just that you don't get a nice html error in the thumbnail that states this (like PNGs do with the 12.5 Mpixel limit). It is visible if you open the thumbnail itself in the browser or in a texteditor.

Only File:London_Interdean_office.tif is rather weird in that it produces no error output at all.

http://commons.wikimedia.org/wiki/Category:Scanned_French_books_in_TIFF is also interesting, it doesn't generate thumbs nor errors there, but as to why, i'm unsure.
Comment 11 Jeff G. 2011-02-13 20:53:02 UTC
A similar problem is in [[Commons:Category:Hermitage hi-res TIFF files from a .torrent]], where 11 of 15 images (73%) are not thumbnailing.  If there is an exactly 12.5 megapixels (12,500,000 pixels) limit on thumnbnailing TIFF images (and/or others besides PNG images), please update [[Commons:Commons:First steps/Quality and description#Size_and_scaling]] to reflect the current reality and consider increasing that five year old limit.
Comment 13 Tim Starling 2011-02-13 23:53:04 UTC
(In reply to comment #11)
> A similar problem is in [[Commons:Category:Hermitage hi-res TIFF files from a
> .torrent]], where 11 of 15 images (73%) are not thumbnailing.  If there is an
> exactly 12.5 megapixels (12,500,000 pixels) limit on thumnbnailing TIFF images
> (and/or others besides PNG images), please update [[Commons:Commons:First
> steps/Quality and description#Size_and_scaling]] to reflect the current reality
> and consider increasing that five year old limit.

It's a wiki, you can edit that page yourself.

The limit will be increased when VIPS support is added, i.e. bug 25990.
Comment 14 Jeff G. 2011-02-14 04:07:56 UTC
(In reply to comment #13)
> (In reply to comment #11)
> > A similar problem is in [[Commons:Category:Hermitage hi-res TIFF files from a
> > .torrent]], where 11 of 15 images (73%) are not thumbnailing.  If there is an
> > exactly 12.5 megapixels (12,500,000 pixels) limit on thumbnailing TIFF images
> > (and/or others besides PNG images), please update [[Commons:Commons:First
> > steps/Quality and description#Size_and_scaling]] to reflect the current reality
> > and consider increasing that five year old limit.
> 
> It's a wiki, you can edit that page yourself.

Thank you, I did so in http://commons.wikimedia.org/w/index.php?title=Commons:First_steps/Quality_and_description&diff=49759608&oldid=49523951 . What other formats (if any) are subject to that limit?
 
> The limit will be increased when VIPS support is added, i.e. bug 25990.

Thank you, that will be a welcome addition, as 21.1 megapixel cameras like the Canon EOS 5D Mark II are already available off the shelf.  When do you expect that addition to take place?  Thanks again.
Comment 15 Bugmeister Bot 2011-08-19 19:12:31 UTC
Unassigning default assignments. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/54734
Comment 16 matanya 2012-08-14 01:22:27 UTC

*** This bug has been marked as a duplicate of bug 25647 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links