Last modified: 2014-06-23 16:07:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24671 - "Previous" revision link on oldest version of wiki article points to a *newer* revision
"Previous" revision link on oldest version of wiki article points to a *newer...
Status: RESOLVED DUPLICATE of bug 2930
Product: MediaWiki
Classification: Unclassified
History/Diffs (Other open bugs)
1.21.x
All All
: Low minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 11:26 UTC by Felix Pahl
Modified: 2014-06-23 16:07 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Felix Pahl 2010-08-05 11:26:35 UTC
This page: http://en.wikipedia.org/w/index.php?title=London&direction=prev&oldid=331657753 has a "Previous revision" link even though it's the oldest version of the page. If you click on the link, there's a delay and then after a while some other revision is displayed.
Comment 1 Chad H. 2010-08-06 12:37:34 UTC
When looking at the earliest part of the history, it would seem the two oldest revs (8th and 28th October, 2001) have rev ids referring to *much* newer revs. The oldest *intact* revision seems to be from 11 November 2001, http://en.wikipedia.org/w/index.php?title=London&oldid=263882.

It seems as though it's been moved over the course of its history as well...dunno if older moves were buggy, or perhaps it's the text corruption from bug 20757 showing up again.
Comment 2 Mark A. Hershberger 2013-09-26 17:20:25 UTC
Just saw this on https://en.wikipedia.org/w/index.php?title=Italy&oldid=258502 and decided to update this bug instead of filing a new one.
Comment 3 Kevin Israel (PleaseStand) 2013-09-27 05:36:51 UTC
Correct me if I'm wrong.

*** This bug has been marked as a duplicate of bug 2930 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links