Last modified: 2014-04-07 17:27:36 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24488 - Don't encourage users to insert deprecated presentational tags by presence of such buttons on edit toolbar
Don't encourage users to insert deprecated presentational tags by presence of...
Status: RESOLVED DUPLICATE of bug 38487
Product: MediaWiki extensions
Classification: Unclassified
WikiEditor (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 24493
  Show dependency treegraph
 
Reported: 2010-07-22 10:10 UTC by Danny B.
Modified: 2014-04-07 17:27 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Danny B. 2010-07-22 10:10:08 UTC
The edit toolbar should not contain buttons which insert deprecated presentational tags, such as <big> or <small>, which encourage users to use them, although they should not.
Comment 1 p858snake 2010-07-22 10:14:16 UTC
Um, were they ever actually part of the html specs, i thought we just made up
the Big and Small?
Comment 2 Roan Kattouw 2010-07-22 10:21:06 UTC
(In reply to comment #1)
> Um, were they ever actually part of the html specs, i thought we just made up
> the Big and Small?
No, we didn't make them up, they're HTML tags. Look at the HTML output of previewing <big>foo</big> and you'll see it's really just <big>foo</big>
Comment 3 Danny B. 2010-07-22 11:47:10 UTC
This actually suggests another possible solution (which should be another bug though) - keep <big> and <small> but render them as <span class="big/small"> (with appropriate other attributes coming from the original tag. Just for the record,so it won't get forgotten.
Comment 4 parul 2010-07-22 20:08:07 UTC
if i remember correctly, these buttons were used in our old (and new?) tool bar click tracking in japanese.  with our other font size issues in script language, i wouldn't be surprised if this was the case for chinese, korean, etc.......

we were actually going to take these out a while back until we saw that data and decided to keep it in until another point of view (read:  pleas to remove them) surfaced.
Comment 5 Krinkle 2011-06-22 00:30:08 UTC
*Mass-change: Move WikiEditor bugs to component and remove blocker bug where*
Comment 6 Bugmeister Bot 2011-08-19 19:12:53 UTC
Unassigning default assignments. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/54734
Comment 7 Derk-Jan Hartman 2014-04-07 17:27:36 UTC

*** This bug has been marked as a duplicate of bug 38487 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links