Last modified: 2013-06-18 15:55:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24445 - Invalidate full cache of math image on WMF
Invalidate full cache of math image on WMF
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Low normal with 2 votes (vote)
: ---
Assigned To: Tim Starling
: shell
: 15057 29770 (view as bug list)
Depends on: 16719
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 18:34 UTC by Umherirrender
Modified: 2013-06-18 15:55 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Umherirrender 2010-07-19 18:34:53 UTC
Please invaldiate/delete the full cache for the rendered math-tags.

After Bug 8 was fixed (go live on 9. April 2010 on the cluster) the old images are all still shown. When have a skin/user style with a non-white backgound, then it looks bad, when one math-tag has a transparent background and the other a white, because the first is rendered after the 9. April 2010.

See also bug 16719.

Thanks.
Comment 1 Antoine "hashar" Musso (WMF) 2011-01-18 20:45:38 UTC
Maybe we could purge the math subfolders (4096 of them) one by one for files before april 9 2010.
We would need some metrics to track the math generation though.
Comment 2 Platonides 2011-03-08 23:28:17 UTC
Another option would be to edit the pngs in place to add the transparency. Feels dirty, though.
Comment 3 p858snake 2011-03-08 23:33:06 UTC
(In reply to comment #1)
I believe this has been disucssed (unsure if it was for clearing the whole lot or just the ones that need it. But there are load issues to contend with.
Comment 4 Tim Starling 2011-03-09 22:31:58 UTC
You can't delete the images, because they are referenced from cached HTML. Unlike thumbnails, there is no way to regenerate them without parsing the articles that refer to them, because only the hash is known, the source LaTeX is not stored in the math table. 

Perhaps we could change the base directory and URL, and have a 404 handler that falls back to the old math directory when an image doesn't exist in the new directory. Then after a few months, we could delete the old directory.

That would be a one-off though. A more permanent solution would be to change the schema, direct all math requests to a script, and implement expiry in MediaWiki.
Comment 5 Bawolff (Brian Wolff) 2011-07-08 15:36:06 UTC
*** Bug 29770 has been marked as a duplicate of this bug. ***
Comment 6 p858snake 2011-09-21 12:09:28 UTC
[20:57] <p858snake|l> (Bug 24445) have we ever really thought about the math cache load issue if we were to totally rebuild it on the wmf cluster? because for 1.18 with how we have it version switched in intsettings we could point it to a new folder to rebuild... but the week turn around between adding more projects is probably to short to do that
Comment 7 Nicholas Longo 2011-10-14 02:42:06 UTC
*** Bug 15057 has been marked as a duplicate of this bug. ***
Comment 8 Umherirrender 2012-07-07 20:25:59 UTC
Looks fixed? Can someone confirm, that there are no pngs with white background exist in cache? Thanks.
Comment 9 Umherirrender 2012-08-27 19:23:45 UTC
Can someone confirm, if this is already fixed? Thanks.
Comment 10 Umherirrender 2012-09-04 18:51:52 UTC
Please add a status info. Thanks.
Comment 11 Umherirrender 2012-09-29 10:45:07 UTC
Math pictures looks good, so there was some changes. Thanks.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links