Last modified: 2013-06-18 13:33:19 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24415 - Implement ResourceLoader 1.0 (tracking)
Implement ResourceLoader 1.0 (tracking)
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
ResourceLoader (Other open bugs)
1.17.x
All All
: Highest enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
: tracking
Depends on: 19995 20776 24862 25124 25144 25252 25260 25286 25322 25330 25338 25339 25382 25386 25402 25486 25491 25529 26324 28738
Blocks: tracking
  Show dependency treegraph
 
Reported: 2010-07-17 13:50 UTC by Roan Kattouw
Modified: 2013-06-18 13:33 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Roan Kattouw 2010-07-17 13:50:17 UTC
This bug tracks bugs that will be fixed by the new resource loader.
Comment 1 DieBuche 2010-09-26 12:30:17 UTC
Bug 24862 could be fixed with this
Comment 2 Ryan Kaldari 2010-09-28 20:03:15 UTC
Isn't this bug set up backwards? A tracking bug normally includes issues that need to be fixed in order to meet a certain milestone or release a certain feature. The bugs that will be fixed by that feature are then listed under "Blocks". Due to how this bug is defined, all the bugs that are blocked by Resource Loader are listed as "Depends on" and those bugs don't have a proper Resource Loader bug to list as a Blocker.

Why don't we just have a bug called "Implement Resource Loader"? All the bugs that would be fixed by it can then be listed as "Blocks" and all the bugs that have to be fixed as part of the Resource Loader implementation would be listed as "Depends on". We don't need to reinvent this functionality by creating a "blocks tracker" (which inverts the normal dependency logic). It's too confusing, IMO.
Comment 3 Michael Dale 2010-10-17 00:56:21 UTC
*** Bug 20776 has been marked as a duplicate of this bug. ***
Comment 4 Michael Dale 2010-10-17 00:56:32 UTC
*** Bug 20777 has been marked as a duplicate of this bug. ***
Comment 5 Ryan Kaldari 2010-10-18 16:54:45 UTC
And now we're marking actual bugs as duplicates of a tracking bug. What a mess.
Comment 6 MZMcBride 2010-10-18 17:13:51 UTC
I'm cleaning this up.

Bug 20776 and bug 20777 have been re-opened. Bug 25491 was re-opened and I changed it to be a block of this bug, rather than a dependency.

I changed this bug's title from "Resource loader (tracking)" to "Implement ResourceLoader (tracking)". I'll update the blocks on other bugs shortly.
Comment 7 Ryan Kaldari 2010-10-18 17:19:06 UTC
Yay!
Comment 8 Krinkle 2011-06-04 17:23:17 UTC
Renaming to 1.0, this should be finished by the end of 1.17 (which is the first release including ResourceLoader)

This bug has been getting a few dependancies lately, some should be moved to the "2.0" implementation tracker (bug 29272), or in general to the new "ResourceLoader" component.
Comment 9 Mark A. Hershberger 2011-06-07 02:14:19 UTC
We're gonna let 1.17 go with version 0.999 of RL if we have to.  Although Bug #24778 shouldn't be hard to fix, I'm told.  So we may still make it.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links