Last modified: 2011-02-08 21:56:19 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24160 - Magic words, templates and parser functions not substituted in <ref> tags
Magic words, templates and parser functions not substituted in <ref> tags
Status: RESOLVED DUPLICATE of bug 2700
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-28 15:57 UTC by Krinkle
Modified: 2011-02-08 21:56 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Krinkle 2010-06-28 15:57:29 UTC
The title pretty much says it all.

See a demo over here:
http://commons.wikimedia.org/wiki/User:Krinkle/Testcase/5

Magic words such as {{formatnum:}} and {{urlencode:}} aren't being substituted within <ref> tags causing it to be spit out raw on the page.

Could be a bug in MediaWiki core or in the Cite.php extension.
Comment 1 Krinkle 2010-06-28 15:58:20 UTC
Changed from enhancement to normal.
Comment 2 Krinkle 2010-06-28 16:05:23 UTC
Regular templates and parser functions aren't being subtituted either.

See the updated demo:
http://commons.wikimedia.org/wiki/User:Krinkle/Testcase/5
Comment 3 [no longer active user] 2010-06-28 16:20:31 UTC
please solve it thanks, it is really needed
Comment 4 Alexandre Emsenhuber [IAlex] 2010-06-28 17:34:00 UTC

*** This bug has been marked as a duplicate of bug 2700 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links