Last modified: 2010-06-16 22:12:24 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24005 - Transcluding special page overwrites page name
Transcluding special page overwrites page name
Status: RESOLVED DUPLICATE of bug 23293
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.15.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 22:01 UTC by Mark Clements (HappyDog)
Modified: 2010-06-16 22:12 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Mark Clements (HappyDog) 2010-06-16 22:01:46 UTC
URL: http://www.mediawiki.org/wiki/User:HappyDog
Expected behavior: Page title is 'User:HappyDog'
Actual behaviour: Page title is 'Special:Newpages/limit=10'

Many apologies for the vague nature of this bug report, but I have no idea where the bug is here.  It could be a MW bug, something specific to MediaWiki.org, or even something to do with the markup on my user page.  All I know is that this didn't used to be a problem, and now it is, and my page has not been edited in the meantime.
Comment 1 Chad H. 2010-06-16 22:06:02 UTC
Tweaked summary, was able to replicate on my userpage on mediawiki.org, can't replicate in trunk.
Comment 2 Mark Clements (HappyDog) 2010-06-16 22:09:47 UTC
Have done a bit more digging and discovered the following:

Clicking 'edit' on the page gives the correct page title.  However, clicking 'show preview' gives the incorrect title.

Removing the transclusion, {{Special:Newpages/limit=10}}, from the page markup gives the correct page title on 'show preview', so I'm guessing it's a problem with this transclusion (though I haven't tested saving this).
Comment 3 Sam Reed (reedy) 2010-06-16 22:12:24 UTC

*** This bug has been marked as a duplicate of bug 23293 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links