Last modified: 2013-03-06 10:08:44 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23736 - Change conflict issues on highly active pages
Change conflict issues on highly active pages
Status: RESOLVED DUPLICATE of bug 980
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
unspecified
All All
: Low enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 17:43 UTC by stevertigo
Modified: 2013-03-06 10:08 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description stevertigo 2010-05-31 17:43:12 UTC
* Highly active pages (talk pages in particular) have issues with edit conflicts - issues that could be resolved by a careful time-limited (and high-activity only) application of a lock-out feature. Such lock outs would be short, perhaps of only 1 or 2 minutes, but would give continuing/interrupting editors notice, and possibly cue submitted talk comments as diff patches - all in an ordered sequence that minimizes change conflicts. 

* When an change "edit" conflict occurs, the presented fields both contain full article text, which negates the editing (and databasing) benefits/functionality of section editing, and compounds the difficulty in re-collecting added comments from the bottom field, finding the exact section and place where it belongs, and re-adding it. 

-SC
Comment 1 stevertigo 2010-05-31 17:48:19 UTC
(Continuing) Simply refactoring how the change conflict page is displayed could mitigate some of these issues. For example, showing the user's own diff at top would allow them to see first what exactly has occurred, and allow them to re-select the text to paste back into the new edit field. A particulary effective solution could be in printing re-opened section-edit fields rather than the whole page edit fields.

-SC
Comment 2 Nemo 2013-03-06 10:08:44 UTC
(In reply to comment #0)
> * Highly active pages (talk pages in particular) have issues with edit
> conflicts 

Right.

> - issues that could be resolved by a careful time-limited (and
> high-activity only) application of a lock-out feature. Such lock outs would
> be
> short, perhaps of only 1 or 2 minutes, but would give continuing/interrupting
> editors notice, and possibly cue submitted talk comments as diff patches -
> all
> in an ordered sequence that minimizes change conflicts. 

Your proposed solution makes it look a bad idea, but it's not (in general): I call it a duplicate of bug 980.

> 
> * When an change "edit" conflict occurs, the presented fields both contain
> full
> article text, which negates the editing (and databasing)
> benefits/functionality
> of section editing, and compounds the difficulty in re-collecting added
> comments from the bottom field, finding the exact section and place where it
> belongs, and re-adding it. 

That's bug 4745.

(In reply to comment #1)
> (Continuing) Simply refactoring how the change conflict page is displayed
> could
> mitigate some of these issues. For example, showing the user's own diff at
> top
> would allow them to see first what exactly has occurred, and allow them to
> re-select the text to paste back into the new edit field. A particulary
> effective solution could be in printing re-opened section-edit fields rather
> than the whole page edit fields.

Hm, this appears like bug 17177, but is actually different; in a way, it's like bug 980 again, in that we'd like to have a report on merge conflicts like SVN/CVS/Git produce.
The idea was rejected by the proposer there because it would make the edit window too complex, but maybe there's an easy solution we could still profit from, like a way to show what your diff to the revision you were editing was, or anyway to provide the user something better to copy and paste in the edit area to recover the own edit.

*** This bug has been marked as a duplicate of bug 980 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links