Last modified: 2012-04-13 08:59:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23704 - Ignore leading or trailing whitespaces when match lines
Ignore leading or trailing whitespaces when match lines
Status: RESOLVED DUPLICATE of bug 13462
Product: MediaWiki extensions
Classification: Unclassified
wikidiff2 (Other open bugs)
unspecified
All All
: Normal enhancement with 2 votes (vote)
: ---
Assigned To: Tim Starling
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 21:58 UTC by Umherirrender
Modified: 2012-04-13 08:59 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
screenshot of diffs (136.47 KB, image/png)
2010-05-29 08:14 UTC, Umherirrender
Details

Description Umherirrender 2010-05-28 21:58:53 UTC
When have a diff, where the leading or trailing whitespace of some lines is changed, the lines are not matched to its original line. This often happen when diff javascript pages, where the indentation of some lines is changed.

It is possible to ignore leading and trailing whitespaces, when match the lines of the both revision? Thanks.

Example (not javascript page):
http://de.wikipedia.org/w/index.php?title=Daihatsu_Cuore&diff=72851766&oldid=72377298

When adding one space at the end of line 193 the diff works as expected

also works fine with diff other way round:
http://de.wikipedia.org/w/index.php?title=Daihatsu_Cuore&diff=72377298&oldid=72851766
Comment 1 Platonides 2010-05-28 22:26:50 UTC
I see on both cases that space changes result in "white-green" diffs with no red letter.
Maybe we could have a parameter to do ignore-space diffs, or give those lines a different class.
Comment 2 Umherirrender 2010-05-29 08:14:02 UTC
Created attachment 7414 [details]
screenshot of diffs

(In reply to comment #1)
> I see on both cases that space changes result in "white-green" diffs with no
> red letter.
I have add a screenshot of the both links, there are red letters.

> Maybe we could have a parameter to do ignore-space diffs, or give those lines a
> different class.
that is maybe bug 21351
Comment 3 Platonides 2010-05-29 12:14:37 UTC
I see now what you mean.
The line * Neu: Servolenkung, Zentralverriegelung,... got a space difference and moved down in the comparison for no good reason.

For the record: this diff seems to be trimming leading spaces.
Comment 4 Nemo 2012-04-13 08:59:39 UTC
(In reply to comment #3)
> I see now what you mean.
> The line * Neu: Servolenkung, Zentralverriegelung,... got a space difference
> and moved down in the comparison for no good reason.

Duping to bug 13462 then.

> For the record: this diff seems to be trimming leading spaces.

More for the record: see for instance the single space removed from the otherwise empty line after the "* Normverbrauch:" line.
It's correct for wikidiff to report such differences, IMHO: they are clearer with the new style and it's still a style change if we want to hide them (make them less visible), so perhaps bug 35923 would be the place.

*** This bug has been marked as a duplicate of bug 13462 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links