Last modified: 2012-09-27 01:11:11 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23575 - Vector is invalid XHTML (empty UL elements)
Vector is invalid XHTML (empty UL elements)
Status: RESOLVED DUPLICATE of bug 23015
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: html
  Show dependency treegraph
 
Reported: 2010-05-18 03:52 UTC by Fran Rogers
Modified: 2012-09-27 01:11 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Fran Rogers 2010-05-18 03:52:18 UTC
As currently running on the English Wikipedia, Vector generates invalid XHTML:

http://validator.w3.org/check?uri=http%3A%2F%2Fen.wikipedia.org%2Fwiki%2FMain_Page&charset=%28detect+automatically%29&doctype=Inline&ss=1&group=0&user-agent=W3C_Validator%2F1.767

This is a regression from Monobook:

http://validator.w3.org/check?uri=http%3A%2F%2Fen.wikipedia.org%2Fw%2Findex.php%3Ftitle%3DMain_Page%26useskin%3Dmonobook&charset=%28detect+automatically%29&doctype=Inline&group=0&user-agent=W3C_Validator%2F1.767

It's invalid because the portlets can be generated with empty UL elements - apparently intended, since the ULs are wrapped in DIVs with the class "emptyPortlet". HTML and XHTML mandate (from HTML 2 onward) that there be at least one LI element inside every UL element.
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2010-05-18 16:36:40 UTC
For the record, this is valid HTML5.  Presumably the logic is that it makes no less sense than an empty div, makes authoring marginally easier, and is harmless.  We still want to output valid XHTML 1.0, so this should prolly be fixed anyway.  Plus it's silly.  :)
Comment 2 Roan Kattouw 2010-05-18 16:41:16 UTC
It's actually not silly at all if you're a script trying to add stuff to that <ul>, and we change the skin so it isn't guaranteed to exist any more.
Comment 3 Aryeh Gregor (not reading bugmail, please e-mail directly) 2010-05-18 16:49:07 UTC
Oddly enough, that's exactly one of the reasons irc://irc.freenode.net/whatwg suggested when I asked why it was valid:

[100518 12:33:03] <AryehGregor> . . . Why is an empty <ul></ul> valid in HTML5?
...
[100518 12:40:57] <jgraham> AryehGregor: The idea was you might fill it in with script or so later iirc

We could just leave this alone, then.  It breaks XHTML1 validation, but will un-break by default when we switch to HTML5.
Comment 4 Roan Kattouw 2010-05-18 21:49:43 UTC

*** This bug has been marked as a duplicate of bug 23015 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links